Partiel Pgc2 .pdf


Nom original: Partiel Pgc2.pdf

Ce document au format PDF 1.3 a été généré par Canon / , et a été envoyé sur fichier-pdf.fr le 18/04/2013 à 17:03, depuis l'adresse IP 86.201.x.x. La présente page de téléchargement du fichier a été vue 1445 fois.
Taille du document: 344 Ko (2 pages).
Confidentialité: fichier public


Aperçu du document


IUT *4" Paul SABATIER

Jeudi l8 Juin2009

Dpt Informatique
st

AP -> complémentsdu langageC : Pgc2
contrôle écrit
d u rée : t h
documents: autonsés

ExerciceI :
de C et dont I'en-têtede
Soit la procédureextraireSousChainedéfiniedansles TP de compléments
I'algorithmegénéral estle suivant:
-- copie nte sous chaînede ch2 dans la chaîne chl.
-- la souschaîne contmenceà la position p et a n caroclèresde long au pltts.
-- lèrc I'exception 'EkR PAR4M " si lesparamètresp e\/ou n sont int,alides.
-- là'e I'exception 'ERR.ALLOC" en cas d'erreur d'allocation dynanique.
-- si une exceptionest levéela chaînechl ne serapas modi/ïée.
( mise-a-iour chl <ChaineDyn>,entrée ch2 <ChaineDyn>.
procédure extraireSousChaine
entréep <Entier>,entréen <Entier>)
I ")- Écrireen C, I'en-têtede cetteprocédure.
2')- Écrire en C. l'appel de cetteprocédure,avec les paramètreseffectifs suivanls :
ChaineDyn chainel, chaine2;
int pos. nbcar:
jmp_buf pointRep;
xercice2 :
Le glossairede I'algorithmegénéralde la procédureextraireSousChaineest le suivani:
lgCh2 <Entier> : longueur de la chaînech2;
lgSousCh2<Entier> : longue,urde la souschaîneà extraire;
pour stockerla
pÛAl1oc<PointeurCar> : pointeursur 1ebloc d'octetsallouédynarniquement
souschaîneà extraire;
l')- Écrire en C, la séquencealgorithmique suivante:
lgCh2 <- ch2.nbCar;
si ( (p'I ) ou (p'lgCh2) ou (n-0) ) alors
lever( ERR_PARAM );
finsi :
2')- Ecrire en C, la séquencealgorithmique suivante:
ptrAlloc <- allouer(lgSousCh2);
si ( ptrAlloc:NULL ) alors
lever ( ERR ALLOC );
finsi;

3')- Ecrire en C, la séquencealgorithmique suivante:
si ( chl .ptrCar !- NULL ) alors
desallouer(chl.ptrCar);
finsi;
chl.nbCar <- lgSousCh2;
chl.ptrCar <- plrAlloc;

Exercice 3 :
Écrire en C, les déclarationset la séquenced'instructionsqui permettentd'ouvrir en lecture le
fichier ./datalliste et d'afficher un messaged'erreuren cas d'échec.

Barème:
ExerciceI :4 pts
Exe r c i c e 2 : l l,5 p ts
Exe r c i c e 3 : 4 ,5 p ts


Aperçu du document Partiel Pgc2.pdf - page 1/2

Aperçu du document Partiel Pgc2.pdf - page 2/2




Télécharger le fichier (PDF)


Partiel Pgc2.pdf (PDF, 344 Ko)

Télécharger
Formats alternatifs: ZIP



Documents similaires


partiel pgc2
serie2 info correction
serie revision corrige
ds 01 b final
correctionseriecoursstructuresconditionnelles
resume si algo

Sur le même sujet..