Fichier PDF

Partage, hébergement, conversion et archivage facile de documents au format PDF

Partager un fichier Mes fichiers Convertir un fichier Boite à outils Recherche Aide Contact



Lab 36 LSInfinity metric for Summary External and Router LSA .pdf



Nom original: Lab 36 LSInfinity metric for Summary External and Router LSA.pdf
Auteur: red med

Ce document au format PDF 1.5 a été généré par Microsoft® Word 2016, et a été envoyé sur fichier-pdf.fr le 23/01/2017 à 15:30, depuis l'adresse IP 154.121.x.x. La présente page de téléchargement du fichier a été vue 200 fois.
Taille du document: 433 Ko (9 pages).
Confidentialité: fichier public




Télécharger le fichier (PDF)









Aperçu du document


Lab 36: LSInfinity metric for Summary External and Router LSA

Basic configuration of all routers:
R1:
ipv uni
!
interface Loopback0
ipv6 address 1::1/64
ipv6 ospf 1 area 0
ipv6 ospf network point-to-point
!
interface Serial1/0
ipv6 address 12::1/64
ipv6 ospf 1 area 0
no sh
!
ipv6 router ospf 1
router-id 0.0.0.1
R2:
ipv uni
!
interface Serial1/0
ipv6 address 12::2/64
ipv6 ospf 1 area 0
no sh
!
interface Serial1/1
ipv6 address 23::2/64
ipv6 ospf 1 area 1
no sh
!
ipv6 router ospf 1
router-id 0.0.0.2
R3:
ipv uni
OSPF INTERACTION WITH RFC
REDOUANE MEDDANE ALL RIGHTS RESERVED

!
interface Loopback0
ipv6 address 3::3/64
!
interface Serial1/0
ipv6 address 23::3/64
ipv6 ospf 1 area 1
no sh
!
ipv6 router ospf 1
router-id 0.0.0.3
redistribute connected route-map CONNECTED
!
route-map CONNECTED permit 10
Verify the routing tables of all routers and ensure that R1 receives the external route 3::/64, R2
receives the intra-area route 1::/64 and the external route 3::/64, and R3 receives the inter-area
route 1::/64:
R1#sh ipv route osp | beg OE2
OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2, l - LISP
OE2 3::/64 [110/20]
via FE80::C802:3FFF:FE8C:8, Serial1/0
OI 23::/64 [110/128]
via FE80::C802:3FFF:FE8C:8, Serial1/0
R1#
R2#sh ipv route osp | beg OE2
OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2, l - LISP
O
1::/64 [110/65]
via FE80::C801:42FF:FE70:8, Serial1/0
OE2 3::/64 [110/20]
via FE80::C803:3DFF:FE00:8, Serial1/1
R2#
R3#sh ipv route osp | beg OE2
OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2, l - LISP
OI 1::/64 [110/129]
via FE80::C802:3FFF:FE8C:8, Serial1/0
OI 12::/64 [110/128]
via FE80::C802:3FFF:FE8C:8, Serial1/0
R3#
Verify the LSDB of R3 and the Type-3 LSA for 1::/64 advertised by the ABR R2, the metric
listed in the LSA is 65 which is the cost to reach 1::/64 from R2's perspective:
R3#sh ipv os data inter-area prefix 1::/64
OSPFv3 Router with ID (0.0.0.3) (Process ID 1)
Inter Area Prefix Link States (Area 1)
Routing Bit Set on this LSA
LS age: 189
OSPF INTERACTION WITH RFC
REDOUANE MEDDANE ALL RIGHTS RESERVED

LS Type: Inter Area Prefix Links
Link State ID: 2
Advertising Router: 0.0.0.2
LS Seq Number: 80000001
Checksum: 0xECC3
Length: 36
Metric: 65
Prefix Address: 1::
Prefix Length: 64, Options: None
R3#
From R3's perspective, the total cost to reach 1::/64 is : 64+65=129
The area range command has some interesting parameters to remove the summarization. Let's
take a look at the cost parameters.
The parameters "cost" is the metric for this summary route, which is used during OSPF SPF
calculation to determine the shortest paths to the destination. The value can be 0 to
16,777,214.
The idea here is to set the cost in the area range command with a cost so that when R4
calculates the total cost to 1::/64 and 4::/64, it finds a value greater than 16777215.
Why the value 16777215 ?
When a router generated a Type-3 LSA or even a Type-5 LSA with the max-age set (3600
seconds). These LSAs with max age set are discarded and the metric is set to 16777215. This
is the maximum metric for routes in the OSPF database in decimal. A route with a metric
higher than 16777215 is inaccessible therefore is discarded from the OSPF database. This
metric is also known as LSInfinity. Setting the metric to 16777215 will force the OSPF process
to remove the LSA from the LSDB. LSinfinity means "unreachable".
R2(config-rtr)#ipv6 router ospf 1
R2(config-rtr)#area 0 range 1::/64 cost ?
<0-16777214> Advertised metric for this range
R2(config-rtr)#
RFC 1583 and RFC 2328 describes the value of LSInfinity for Summary and External LSAs as a
24-bit binary value.
RFC 1583 section B. Architectural Constants:
LSInfinity
The metric value indicating that the destination described by a
link state advertisement is unreachable. Used in summary link
advertisements and AS external link advertisements as an
alternative to premature aging (see Section 14.1). It is defined
to be the 24-bit binary value of all ones: 0xffffff.
RFC 2328 section B. Architectural Constants:
LSInfinity
The metric value indicating that the destination described by an
LSA is unreachable. Used in summary-LSAs and AS-external-LSAs as
OSPF INTERACTION WITH RFC
REDOUANE MEDDANE ALL RIGHTS RESERVED

an alternative to premature aging (see Section 14.1). It is
defined to be the 24-bit binary value of all ones: 0xffffff
The value 24-bit is only valid for external and summary LSAs.
Let's configure area 0 range with a cost 16777152:
R2(config)#ipv router os 1
R2(config-rtr)#area 0 range 1::/64 cost 16777152
Enable the debub ipv osp spf inter command:
R3#debug ipv ospf spf inter
OSPFv3 spf inter events debugging is on for process 1, IPv6, Default vrf
R3#
R3#
*Jan 7 21:41:18.531: OSPFv3-1-IPv6
1
*Jan 7 21:41:18.535: OSPFv3-1-IPv6
2003
*Jan 7 21:41:18.535: OSPFv3-1-IPv6
Type7:0
*Jan 7 21:41:18.535: OSPFv3-1-IPv6
*Jan 7 21:41:18.539: OSPFv3-1-IPv6
0x8000000C (area 1) 1::/64
*Jan 7 21:41:18.539: OSPFv3-1-IPv6
existing 16777215
*Jan 7 21:41:18.543: OSPFv3-1-IPv6
R3#
*Jan 7 21:41:18.543: OSPFv3-1-IPv6
(1/0/1)
*Jan 7 21:41:18.543: OSPFv3-1-IPv6
R3#

SPF

: Changed LSA 0.0.0.2/2, type 2003, area

SPF

: Schedule partial SPF - 0.0.0.2/2 type

SPF

: Service partial SPF Type3/4:1 Type5:0

INTER: Partial IAP SPF, area 1, Prefix 1::/64
INTER:
IAP LSA 0.0.0.2/2, age 1, seq
INTER:

ignore 1::/64, metric 16777216,

INTER: Delete old prefixes
INTER:
INTER:

processing 1::/64, paths (0/1), state
deleting all paths

Let's verify the LSDB of R3, receives the Type-3 LSA for 1::/64 with a metric 16777152:
R3#sh ipv os data inter-area prefix 1::/64
OSPFv3 Router with ID (0.0.0.3) (Process ID 1)
Inter Area Prefix Link States (Area 1)
Routing Bit Set on this LSA
LS age: 48
LS Type: Inter Area Prefix Links
Link State ID: 2
Advertising Router: 0.0.0.2
LS Seq Number: 80000004
Checksum: 0xE34A
Length: 36
Metric: 16777152
Prefix Address: 1::
Prefix Length: 64, Options: None
OSPF INTERACTION WITH RFC
REDOUANE MEDDANE ALL RIGHTS RESERVED

R3#
When R3 calculates the total cost to reach 1::/64 it adds the cost to reach the ABR R2 listed in
the show ipv osp command to the cost listed in the Type-3 LSA : 64+16777152 = 16777216.
R3#sh ipv os border-routers
OSPFv3 Router with ID (0.0.0.3) (Process ID 1)
Codes: i - Intra-area route, I - Inter-area route
i 0.0.0.2 [64] via FE80::C802:3FFF:FE8C:8, Serial1/0, ABR, Area 1, SPF 4
R3#
Since the cost 16777216 of the inter-area route 1::/64 is greater than the LSInfinity 16777215,
R3 considers the routes to 1::/64 unreachable and it will never install the inter-area route:
R3#sh ipv rout os | beg OE2
OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2, l - LISP
OI 12::/64 [110/128]
via FE80::C802:3FFF:FE8C:8, Serial1/0
R3#
Let's verify the LSIfinity with External LSA, on R3 filter the prefix 3::/64 using the distribute-list
command:
Note:
We need to specify the source of the updates (CONNECTED in this case) advertised from
connected into OSPF.
R3(config)#ipv prefix-list FILTER-R3 seq 10 deny 3::/64
R3(config)#ipv prefix-list FILTER-R3 seq 11 permit ::/0 le 128
R3(config)#ipv router osp 1
R3(config-rtr)#distribute-list prefix-list FILTER-R3 out connected
Let's enable the debug ip ospf lsa-generation command:
R4#debug ipv6 ospf lsa-generation
OSPFv3 lsa generation debugging is on for process 1, IPv6, Default vrf
R4#
Immediately after applying the distribute list, R3 generated a Type-5 LSA with the max-age set
(3600 seconds). Remember, LSAs with max age set are discarded. Also, note the metric was
set to 16777215. This is the maximum metric for routes in the OSPF database in decimal as
mentioned by RFC 1583 and RFC 2328. A route with a metric higher than 16777215 is
inaccessible therefore is discarded from the OSPF database. This metric is also known as
LSInfinity.
R3(config-rtr)#
*Jan 7 22:09:02.063: OSPFv3-1-IPv6 LSGEN: Schedule Router LSA area: 1, flag:
Change
*Jan 7 22:09:02.563: OSPFv3-1-IPv6 LSGEN: Suppress unchanged router LSA, area: 1
OSPF INTERACTION WITH RFC
REDOUANE MEDDANE ALL RIGHTS RESERVED

R3(config-rtr)#
*Jan 7 22:09:03.067: OSPFv3-1-IPv6 LSGEN: Generate
4005, age 3600, metric 16777215, tag 0, metric-type
*Jan 7 22:09:03.067: OSPFv3-1-IPv6 LSGEN:
Insert
0x4005 in maxage
R3(config-rtr)#
*Jan 7 22:09:05.683: OSPFv3-1-IPv6 LSGEN:
free
*Jan 7 22:09:05.683: OSPFv3-1-IPv6 LSGEN:
Insert
0x4005 in maxage
R3(config-rtr)#

external LSA 3::/64, type
2, seq 0x80000005
LSA 0 adv_rtr 0.0.0.3, type

check failed 0 0 0 0 0 0
LSA 0 adv_rtr 0.0.0.3, type

Let's verify the LSDB of R2, the Type-5 LSA for 3:/64 is no longer in the database:
R2#sh ipv os data ex
OSPFv3 Router with ID (0.0.0.2) (Process ID 1)
R2#
Verify the routing tables of R2 the external route to 3::/64 diseappers:
R2#sh ipv route os | beg OE2
OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2, l - LISP
O
1::/64 [110/65]
via FE80::C801:42FF:FE70:8, Serial1/0
R2#
However when reading RFC 2328 and RFC 1583, they didn’t mention LSInfinity for Router
LSAs.
So what about Router LSA ?
The value of LSInfinity is defined fortunately in RFC 3137 for OSPF Stub Router Advertisement
in the following section with an example:
To address both problems, router X announces its router-LSA to the
neighbors as follows.
-costs of all non-stub links (links of the types other than 3)
are set to LSInfinity (16-bit value 0xFFFF, rather than 24-bit
value 0xFFFFFF used in summary and AS-external LSAs).
-costs of stub links (type 3) are set to the interface output
cost.
To test let's enable the graceful shutdown feature by using the max-metric router-lsa
command on R1, as a result it is forced to advertise the Type-1 LSA and the Type-9 LSA with
an infinite metric 65535 known as LSInfinity.
Before configuring the graceful shutdown feature, let's verify the Type-1 and Type-9 LSAs
advertised by R1:
Note:
In OSPFv3, the Type-1 and Type-2 LSAs no longer carry any addressing information. They only
carry a description of topology adjacencies. IPv6 prefixes are carried in a Type-9 and Type-8
LSAs.
OSPF INTERACTION WITH RFC
REDOUANE MEDDANE ALL RIGHTS RESERVED

The Type-1 LSA originated by R1 has a metric of 64 , R2 sees and can reach the neighbor R1
with a cost 64:
R2#sh ipv os database router adv 0.0.0.1
OSPFv3 Router with ID (0.0.0.2) (Process ID 1)
Router Link States (Area 0)
LS age: 12
Options: (V6-Bit, E-Bit, R-bit, DC-Bit)
LS Type: Router Links
Link State ID: 0
Advertising Router: 0.0.0.1
LS Seq Number: 80000009
Checksum: 0x2F7E
Length: 40
Number of Links: 1
Link connected to: another Router (point-to-point)
Link Metric: 64
Local Interface ID: 4
Neighbor Interface ID: 4
Neighbor Router ID: 0.0.0.2

R2#
The Type-9 LSA originated by R1 has a metric 1 for the prefix 1::/64:
R2#sh ipv os data prefix adv 0.0.0.1
OSPFv3 Router with ID (0.0.0.2) (Process ID 1)
Intra Area Prefix Link States (Area 0)
Routing Bit Set on this LSA
LS age: 902
LS Type: Intra-Area-Prefix-LSA
Link State ID: 0
Advertising Router: 0.0.0.1
LS Seq Number: 80000004
Checksum: 0xB669
Length: 56
Referenced LSA Type: 2001
Referenced Link State ID: 0
Referenced Advertising Router: 0.0.0.1
Number of Prefixes: 2
Prefix Address: 1::
Prefix Length: 64, Options: None, Metric: 1
Prefix Address: 12::
Prefix Length: 64, Options: None, Metric: 64

OSPF INTERACTION WITH RFC
REDOUANE MEDDANE ALL RIGHTS RESERVED

R2#
Let's configure the max-metric router-lsa command:
Note:
Without the "stub-prefix-lsa" keyword the command changed the metric listed in the LSA Type
1 only, it does not affect the LSA Type 9, to force the router to set the metric of the LSA Type 9
to an unfinite metric we need to add the "stub-prefix-lsa" keyword.
R1(config)#ipv router os 1
R1(config-rtr)#max-metric router-lsa stub-prefix-lsa
Verify the Type-1 LSA 's R1, the metric listed is 65535:
R2#sh ipv os database router adv 0.0.0.1
OSPFv3 Router with ID (0.0.0.2) (Process ID 1)
Router Link States (Area 0)
LS age: 209
Options: (V6-Bit, E-Bit, R-bit, DC-Bit)
LS Type: Router Links
Link State ID: 0
Advertising Router: 0.0.0.1
LS Seq Number: 80000008
Checksum: 0xAE40
Length: 40
Number of Links: 1
Link connected to: another Router (point-to-point)
Link Metric: 65535
Local Interface ID: 4
Neighbor Interface ID: 4
Neighbor Router ID: 0.0.0.2

R2#
Verify the Type-9 LSA 's R1, the metric listed is 65535:
R2#sh ipv os data prefix adv 0.0.0.1
OSPFv3 Router with ID (0.0.0.2) (Process ID 1)
Intra Area Prefix Link States (Area 0)
Routing Bit Set on this LSA
LS age: 67
LS Type: Intra-Area-Prefix-LSA
Link State ID: 0
Advertising Router: 0.0.0.1
LS Seq Number: 80000005
Checksum: 0x1B45
OSPF INTERACTION WITH RFC
REDOUANE MEDDANE ALL RIGHTS RESERVED

Length: 56
Referenced LSA Type: 2001
Referenced Link State ID: 0
Referenced Advertising Router: 0.0.0.1
Number of Prefixes: 2
Prefix Address: 1::
Prefix Length: 64, Options: None, Metric: 65535
Prefix Address: 12::
Prefix Length: 64, Options: None, Metric: 65535
R2#
Let's verify the routing tables of R2 and R3, the intra-area route is still there:
R2#sh ipv route os | beg OE2
OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2, l - LISP
O
1::/64 [110/65599]
via FE80::C801:42FF:FE70:8, Serial1/0
OE2 3::/64 [110/20]
via FE80::C803:3DFF:FE00:8, Serial1/1
R2#
R3#sh ipv route os | beg OE2
OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2, l - LISP
OI 1::/64 [110/65663]
via FE80::C802:3FFF:FE8C:8, Serial1/0
OI 12::/64 [110/128]
via FE80::C802:3FFF:FE8C:8, Serial1/0
R3#
Finally keep in mind that LSInfinity has two different meanings and two different values:



16-bit (65535) for Router LSA.
24-bit (16777215) for Summary LSA and External LSA.

However the key point here is that LSInfinity has two different meanings. For Summary and
External LSAs, LSInfinity 16777215 means "unreachable".
For Router LSAs LSInfinity 65535 means "least desirable". It ensures other routers to use
other Type-1 LSAs stored in their LSDB. it’s possible to have a valid route with an LSInfinite
cost.

OSPF INTERACTION WITH RFC
REDOUANE MEDDANE ALL RIGHTS RESERVED


Documents similaires


Fichier PDF lab 36 lsinfinity metric for summary external and router lsa
Fichier PDF toutes les commandes cisco
Fichier PDF documentation technique 1
Fichier PDF ipanycats
Fichier PDF greatpyramid english
Fichier PDF exam specifications fs references web 2010


Sur le même sujet..