corect.ex2.2017 (1) INF .pdf


Nom original: corect.ex2.2017 (1) INF.pdf
Titre: Ex1(6pts)
Auteur: ASSOU96

Ce document au format PDF 1.5 a été généré par Microsoft® Office Word 2007, et a été envoyé sur fichier-pdf.fr le 17/05/2017 à 09:33, depuis l'adresse IP 105.105.x.x. La présente page de téléchargement du fichier a été vue 302 fois.
Taille du document: 167 Ko (2 pages).
Confidentialité: fichier public


Aperçu du document


Université Mohamed Kheider – Biskra
Faculté des sciences et de la technologie
commun domaine sciences et techniques
Module : Informatique 2

Questions cours

Date :16/05/2017 Tronc
Niveau: 1èreAnnée

4pts

1-procedure : paramètres d’entrée, paramètres de sortie et paramètres mixte(entrée/sortie).
2-fonction : paramètres entrée.

Ex1
a- 4pts

b- 2pts

Algorithme impair ;

program impair ;

Variables i :Entier ;

var i :integer ;

Début

begin

i← 1 ;

i :=1 ;

tantque i<=100) faire

while i<=100 do

Ecrire( i ,’ est impair ‘)

begin

i ←i+2

writeln(i ,‘est impaire’) ;

fintq

i :=i+2 ;

Fin.

end ;
End.

Ex2 : 4pts
Algorithme maxmin
Constante m=30
Variables T1 :tableau[1..m] d’entier ;
max,min :entier

1.5pts

i :entier
debut
max←T1[1] ;

min←T1[1] ;

pour i=2 à m faire
si T1[i]>max alors
max← T1[i]
finsi
si T1[i]<min alors
min← T1[i]
finsi
finp
ecrire(max,min)
Fin.

2.5pts

Université Mohamed Kheider – Biskra
Faculté des sciences et de la technologie
commun domaine sciences et techniques
Module : Informatique 2

Ex3
1- Fonction fact (m : entier) : entier

1.5pts

Var i,f : entier
Debut
F1
Pour i=1 à m faire
F f*i
Finp
Factf
Fin ;
2- procedure fact (m : entier ; var f : entier)
Var i : entier
Debut
F1
Pour i=1 à m faire
F f*i
Finp
Fin ;
2- Algorithme calcul

1pts

var n,p,i : entier
c: reel
Fonction fact (m : entier) : entier
Var i,f : entier
Debut
F1
Pour i=1 à m faire
F f*i
Finp
Factf
Fin ;
Debut

(2pts)

Lire(n,p)
C fact(n) / ((fact(p)*fact(n-p))
Ecrire (‘le factoriel=’,c).
Fin.

1.5pts

Date :16/05/2017 Tronc
Niveau: 1èreAnnée


Aperçu du document corect.ex2.2017 (1) INF.pdf - page 1/2

Aperçu du document corect.ex2.2017 (1) INF.pdf - page 2/2




Télécharger le fichier (PDF)




Sur le même sujet..





Ce fichier a été mis en ligne par un utilisateur du site. Identifiant unique du document: 00512796.
⚠️  Signaler un contenu illicite
Pour plus d'informations sur notre politique de lutte contre la diffusion illicite de contenus protégés par droit d'auteur, consultez notre page dédiée.