Fichier PDF

Partage, hébergement, conversion et archivage facile de documents au format PDF

Partager un fichier Mes fichiers Convertir un fichier Boite à outils PDF Recherche PDF Aide Contact



Structures Conditionnelles .pdf



Nom original: Structures Conditionnelles.pdf
Titre: Structures Conditionnelles
Auteur: hp

Ce document au format PDF 1.4 a été généré par PDFCreator Version 1.5.0 / GPL Ghostscript 9.05, et a été envoyé sur fichier-pdf.fr le 25/11/2017 à 19:59, depuis l'adresse IP 41.230.x.x. La présente page de téléchargement du fichier a été vue 255 fois.
Taille du document: 410 Ko (9 pages).
Confidentialité: fichier public




Télécharger le fichier (PDF)









Aperçu du document


Structures de contrôle
Sommaire
Présentation ......................................................................................................................................................................... 2
Les instructions séquentiels ......................................................................................................................................... 2

I.
1)

En analyse : Ecrire une analyse qui permet la saisie d'un entier N et l'affichage du caractère d''ordre ascii N ..... 2

2)

En algorithme : Ecrire l'algorithme qui permet la traduction de l'analyse entierCaractere ................................... 2

3) En pascal : Ecrire le programme pascal qui permet la traduction de l'algorithme entierCaractere.......................... 2
Les structures conditionnelles ..................................................................................................................................... 3

II.
1)

Structures conditionnelles simple Si ..... alors ..... fin SI......................................................................................... 3
a.

En analyse : Ecrire une analyse qui permet la saisie d'un entier et afficher si l'entier pair ................................. 3

b.

En algorithme : Ecrire un algorithme qui permet la traduction de l'analyse entierParite ................................... 3

c.

En pascal : Ecrire un programme entierParite qui permet la traduction de l'algorithme entierParite ............... 3

2)

Structures conditionnelles alternatives Si ..... alors ..... sinon ..... fin Si ................................................................. 4
a. En analyse : Ecrire une analyse qui permet la saisie d'un chaine de caractères et afficher sa longueur dans le
cas où est paire et la moitié de sa longueur dans le cas contraire .............................................................................. 4
b.

En algorithme : Ecrire un algorithme qui permet la traduction de l'analyse chaineParite .................................. 5

c.

En pascal : Ecrire un programme qui permet la traduction de l'algorithme chaineParite .................................. 5

3)

Structures conditionnelles Généralisée SI ..... ALORS ..... SINON SI ... NON [...] FIN SI FIN SI ............................. 6
a.

En analyse : Ecrire une analyse qui permet d'afficher le résultat d'une équation de second degré ................... 6

b.

En algorithmique : Ecrire un algorihme qui permet la traduction de l'analyse secondDegreSolution................ 6

c.

En algorithmique : Ecrire un programme qui permet la traduction de l'algorithme secondDegreSolution....... 7

4)

Structures conditionnelles à choix multiple SELON ..... FAIRE ..... SINON .... FIN SELON ....................................... 7
a. En analyse : Ecrire une analyse qui permet d'afficher le nom de la forme géométrique à partir du nombre des
côtés ............................................................................................................................................................................. 7
b.

En algorithmique : Ecrire un algorithme qui permet la traduction de l'analyse formeGeometrique.................. 8

c.

En Pascal : Ecrire un programme la traduction de l'algorithme formeGeometrique .......................................... 9

1

Niveau Scolaire : 4ème Sciences Expérimentales

préparé par Khaoula ABAIDI

Présentation
Les structures de contrôle décrivent l’enchaînement des instructions. Elles permettent des traitements
séquentiels, conditionnels ou répétitifs (itératifs).
Les structures séquentiels : les instructions d’un même bloc sont exécutées séquentiellement, c’est-à-dire, les
unes après les autres, donc dans l’ordre où elles sont écrites.

Les structures conditionnelles : les instructions sont exécutées lorsque une condition est vraie
Les structures répétitifs : les instructions sont exécutées d'une manière répétitif lorsque une condition est
vraie

I. Les instructions séquentiels
1) En analyse : Ecrire une analyse qui permet la saisie d'un entier N et l'affichage du caractère d''ordre ascii
N
Nom = entierCaractere
Résultat = Ecrire ("Le caractère est ", c)
c ← chr(N)
N = donnée("Saisie d''un entier N = ")
Fin entierCaractere

2) En algorithme : Ecrire l'algorithme qui permet la traduction de l'analyse entierCaractere
0)debut entierCaractere
1) Ecrire("Saisie d''un entier N = "),lire(N)
2) c ← chr(N)
3) Ecrire ("Le caractère est ", c)
4) Fin entierCaractere
3) En pascal : Ecrire le programme pascal qui permet la traduction de l'algorithme entierCaractere
Program entierCaractere;
Uses wincrt;
Var N : integer ; C : char ;
Begin
Write('Saisie d''entier N = ');readln(N);
c := chr(N); write(c);
end.
2

Niveau Scolaire : 4ème Sciences Expérimentales

préparé par Khaoula ABAIDI

II. Les structures conditionnelles
1) Structures conditionnelles simple Si ..... alors ..... fin SI
La conditionnelle permet d'exécuter une séquence d'instructions si la condition(une expression booléenne) est
vraie. La condition est évaluée , si la condition est vraie alors la séquence est exécutée puis le contrôle passe à la
suite.si la condition est fausse, le contrôle passe à la suite sans exécuter la séquence.

a. En analyse : Ecrire une analyse qui permet la saisie d'un entier et afficher si l'entier pair
Nom = entierParite
Résultat = Ecrire ("est ce que l''entier ", e," est pair ? ",msg)
msg = [ ] si (e mod 2 = 0)
alors msg ← vrai
fin Si
e = donnée("Saisie d''un entier e = ")
fin entierParite
Généralement : [Initialisation] Si condition alors sequenceSiVraie fin Si
b. En algorithme : Ecrire un algorithme qui permet la traduction de l'analyse entierParite
0) debut entierParite
1) Ecrire("Saisie d''un entier e = ") , lire(e)
2) si (e mod 2 = 0)
alors msg ← vrai
fin Si
3) Ecrire ("est ce que l''entier ", e," est pair ? ",msg)
4) fin entierParite
Généralement : [Initialisation], Si condition alors sequenceSiVraie fin Si
c. En pascal : Ecrire un programme entierParite qui permet la traduction de l'algorithme entierParite
Program entierParite ; Uses wincrt;
Var e : integer; msg : boolean;
begin
write('Saisie d''un entier e = ') ; readln(e);
if (e mod 2 = 0) then msg := true ;
write ('est ce que l''entier ', e,' est pair ? ',msg);
end.
Généralement : if condition then { instruction si la condition est vraie} ;
3

Niveau Scolaire : 4ème Sciences Expérimentales

préparé par Khaoula ABAIDI

Dans le cas où une séquence d'instructions exécutée si la condition est vraie , on utilise BEGIN ..END;
Program entierParite2 ;
Uses wincrt;
Var e : integer; msg : boolean;ch : string;
begin
write('Saisie d''un entier e = ') ; readln(e);
if (e mod 2 = 0) then
begin
msg := true ; ch := ' est un entier pair';
end;
write ('est ce que l''entier ', e,' est pair ? ',msg,ch);
end.

2) Structures conditionnelles alternatives Si ..... alors ..... sinon ..... fin Si
La conditionnelle permet d'exécuter une séquence 1 d'instructions si la condition est vraie et la séquence 2
d'instructions si la condition est fausse . Dans tous les cas l'exécution de la suite des instructions après la structure Si
seront exécutées.

a. En analyse : Ecrire une analyse qui permet la saisie d'un chaine de caractères et afficher sa longueur
dans le cas où est paire et la moitié de sa longueur dans le cas contraire
Nom = chaineParite
Résultat = Ecrire (longueur)
longueur = [longueur ←0 ] si (l mod 2 = 0) alors longueur ← l
sinon longueur ← l div 2
fin Si
l ← long(ch)
ch = donnée("CH = ")
fin chaineParite

Généralement : [Initialisation] Si condition alors sequence1 sinon sequence2 fin Si

4

Niveau Scolaire : 4ème Sciences Expérimentales

préparé par Khaoula ABAIDI

b. En algorithme : Ecrire un algorithme qui permet la traduction de l'analyse chaineParite
0) debut chaineParite
1) ecrire("CH = ") , lire(ch)
2) l ← long(ch)
3) longueur ←0 , si (l mod 2 = 0) alors longueur ← l sinon longueur ← l div 2 fin Si
4) Ecrire (longueur)
5) fin chaineParite

Généralement : [Initialisation] Si condition alors sequence1 sinon sequence2 fin Si
c. En pascal : Ecrire un programme qui permet la traduction de l'algorithme chaineParite
Program chaineParite ;uses wincrt ;
Var ch : string ; l, longueur : integer ;
Begin
write('CH = ') ; readln(ch) ;
l := length(ch); longueur :=0 ;
if (l mod 2 = 0) then longueur := l else longueur := l div 2 ;
write (longueur);
end.
Généralement : [Initialisation] if condition then sequence1 else sequence2 ;
Dans le cas où une séquence d'instructions exécutée si la condition est vraie , on utilise BEGIN ..END;

Le ; n'existe pas avant un else puisque la structure n'est pas encore terminée
if CONDITION then
BEGIN

{Séquence1}
END

else
BEGIN

{Séquence2}
END;

Remarque !!!
Il est possible d'imbriquer les structures conditionnelles les unes à l'intérieur des autres
5

Niveau Scolaire : 4ème Sciences Expérimentales

préparé par Khaoula ABAIDI

3) Structures conditionnelles Généralisée SI ..... ALORS ..... SINON SI ... NON [...] FIN SI FIN SI
La conditionnelle généralisée permet de résoudre des problèmes comportant plus de deux traitements en fonction
des conditions .

a. En analyse : Ecrire une analyse qui permet d'afficher le résultat d'une équation de second degré
Nom = secondDegreSolution
Résultat = (s1,s2) = [ ] si delta > 0 alors
s1 ←- b - racineCarre(delta)/(2 * a)
s2 ← - b + racineCarre (delta) /(2 * a)
Ecrire ( s1, " " ,s2)
sinon si delta = 0 alors s1 ← - b /(2 * a) , Ecrire ( s1) sinon
Ecrire (" pas de Solution ")
fin si
delta ← carre ( b ) - 4 * a * c
(a, b , c) = donnée
fin secondDegreSolution

b. En algorithmique : Ecrire un algorihme qui permet la traduction de l'analyse secondDegreSolution
0) Début secondDegreSolution
1) lire( a ), lire( b) , lire (c )
2) delta ← carre ( b ) - 4 * a * c
3) si delta > 0 alors
s1 ←- b - racineCarre(delta)/(2 * a)
s2 ← - b + racineCarre (delta) /(2 * a)
Ecrire (s1, " ",s2)
sinon si delta = 0 alors
s1 ← - b /(2 * a)
Ecrire( s1)
Sinon Ecrire (" pas de Solution ") fin si
4) fin secondDegreSolution

6

Niveau Scolaire : 4ème Sciences Expérimentales

c. En algorithmique : Ecrire un programme
secondDegreSolution

préparé par Khaoula ABAIDI

qui permet la traduction de l'algorithme

PROGRAM secondDegreSolution ;
USES wincrt ;
VAR a, b , c, delta, s1, s2 : real;
BEGIN
readln(a) ; readln(b) ; readln(c) ;
delta := sqr ( b ) - 4 * a * c ;
IF delta > 0 THEN
BEGIN

s1 := - b - sqrt(delta)/(2 * a) ; s2 := - b + racineCarre (delta) /(2 * a) ;
write (s1, ' ',s2);
END

ELSE IF delta = 0 THEN
BEGIN

s1 := - b /(2 * a) ;write( s1) ;
END

ELSE write (' pas de Solution ') ;
END.

4) Structures conditionnelles à choix multiple SELON ..... FAIRE ..... SINON .... FIN SELON
La conditionnelle permet d'exécuter une séquence i d'instructions selon le sélecteur.

a. En analyse : Ecrire une analyse qui permet d'afficher le nom de la forme géométrique à partir du
nombre des côtés
Nom = formeGeometrique
Résultat = Ecrire ("La forme geometrique ayant " ,ncote," côtés est ", msg)
[ncote = donnée("Nombre de cote = "), msg ←[] ]
selon ncote faire
3 : msg ←"Triangle"
4 : msg ←"Carre"
5 : msg ←"Pentagone"
7

Niveau Scolaire : 4ème Sciences Expérimentales

préparé par Khaoula ABAIDI

6 : msg ←"Hexagone"
7 : msg ←"Heptagone"
8 : msg ←" Octogone "
9 : msg ←" Ennegone "
10 : msg ←" Décagone "
11 : msg ←" Hendécagone "
12 : msg ←" Dodécagone "
Sinon msg ←" INVALIDE "
Fin Selon
fin formeGeometrique

b. En algorithmique : Ecrire un algorithme qui permet la traduction de l'analyse formeGeometrique
0) Début formeGeometrique
1) Ecrire("Nombre de cotes = "),lire(ncote), msg ←""
2) selon ncote faire
3 : msg ←"Triangle"
4 : msg ←"Carre"
5 : msg ←"Pentagone"
6 : msg ←"Hexagone"
7 : msg ←"Heptagone"
8 : msg ←" Octogone "
9 : msg ←" Ennegone "
10 : msg ←" Décagone "
11 : msg ←" Hendécagone "
12 : msg ←" Dodécagone "
Sinon
msg ←" INVALIDE " Fin Selon
3) Ecrire ("La forme geometrique ayant " ,ncote," côtés est ", msg)
4) fin formeGeometrique
8

Niveau Scolaire : 4ème Sciences Expérimentales

préparé par Khaoula ABAIDI

c. En Pascal : Ecrire un programme la traduction de l'algorithme formeGeometrique
PROGRAM formeGeometrique ;
USES wincrt ;
Var msg : string;ncote : byte ;
Begin
write('Nombre du cote = ');readln(ncote);msg := '';
case ncote of
3 : msg : = 'Triangle' ;
4 : msg := 'Carre' ;
5 : msg := 'Pentagone' ; 6 : msg := 'Hexagone';
7 : msg := 'Heptagone' ; 8 : msg := ' Octogone';
9 : msg := 'Ennegone' ; 10 : msg := 'Décagone ' ;
11 : msg := 'Hendécagone' ; 12 : msg := 'Dodécagone'
else
msg := 'INVALIDE';
end ;
END.

Remarque :

Le sélecteur doit être de type scalaire ( entier , caractère)

Le cas où un même traitement est exécuté par un intervalle de valeurs ou plusieurs valeurs , la structure selon sera
comme suit :

EN ANALYSE ET ALGORTIHMIQUE

EN PASCAL

[INTIALISATION] SELON selecteur FAIRE

{INTIALISATION}

Cas1 .. CasF : { --- TRAITEMENT 1 ---}

case selecteur of

CasJ .. CasL , casW, casZ : { --- TRAITEMENT 2 ---}

Cas1 .. CasF : { --- TRAITEMENT 1 ---}

sinon { --- TRAITEMENT 3 ---}

CasJ .. CasL , casW, casZ : { --- TRAITEMENT 2 ---}

fin selon

ELSE { --- TRAITEMENT 3 ---}
End ;

9


Documents similaires


structures conditionnelles
structures repetitives 5
correctionseriecoursstructuresconditionnelles
serie support cours
serie support cours corrige
chapitre 2


Sur le même sujet..