Serie Support Cours .pdf



Nom original: Serie Support Cours.pdfTitre: Serie Support CoursAuteur: hp

Ce document au format PDF 1.4 a été généré par PDFCreator Version 1.5.0 / GPL Ghostscript 9.05, et a été envoyé sur fichier-pdf.fr le 10/12/2017 à 11:20, depuis l'adresse IP 41.224.x.x. La présente page de téléchargement du fichier a été vue 569 fois.
Taille du document: 220 Ko (5 pages).
Confidentialité: fichier public


Aperçu du document


MINISTERE EDUCATION TUNISIENNE
--- --------------------------------------------------------

SERIE 03 : Les structures Répétitives
[Support Cours]

Epreuve :
Informatique
Section :
Sciences Expérimentales
Durée : 2 heures
Coefficient :
1
Classe : 4 sciences Expérimentales 2

Exercice 01 :
a) Ecrire un algorithme qui permet le calcul de xy tel que x et y sont deux entiers donnés
comme suit :
Soit x = 2 , y = 4 alors 24 = 16
b) Traduire l'algorithme en un programme pascal

Exercice 02 :
a) Ecrire une analyse qui permet la vérification d'une chaine ayant tous ces caractères
majuscules
b) Transformer l'analyse en un algorithme intitulé majuscule

Exercice 03 :
a) Ecrire une analyse qui permet la suppression des espaces existant au début d'une
chaine de caractères
b) Traduire l'analyse précédente en un algorithme
c) Traduire l'algorithme en un programme pascal nommé suppressionEspaceDebut

Exercice 04 :
a) Ecrire une analyse qui permet la saisie d'un entier n tel que n dans l'intervalle [10 ..100]
b) Ecrire un algorithme qui permet la saisie d'un réel strictement positif
c) Ecrire un programme pascal qui permet la vérification d'une chaine contenant
seulement des chiffres

Exercice 05 :
a) Ecrire un algorithme qui permet d'afficher tous les diviseurs d'un entier n > 0
b) Ecrire un algorithme qui permet le calcul du PGCD de deux entiers par la méthode des
différences expliqué comme suit :

c) Ecrire un algorithme qui permet d'afficher la somme des N les entiers positifs pairs tel
que N est un entier donné composé par trois chiffres
Samedi 09 décembre 2017

Année scolaire : 2017 - 2018

MINISTERE EDUCATION TUNISIENNE
--- --------------------------------------------------------

Correction : Les structures Répétitives
[Support Cours]

Epreuve :
Informatique
Section :
Sciences Expérimentales
Durée : 2 heures
Coefficient :
1
Classe : 4 sciences Expérimentales 2

Exercice 01 :
Algorithme : Calcul xy
0) debut exposant
1) ecrire( ʺ x = ʺ), lire(x)
2) ecrire(ʺ y = ʺ) , lire(y)
3) z = [z ← 1] pour i de 1 à y faire
z←z*x
fin pour
4) ecrire(x, ʺ exposant ʺ , y , ʺ = ʺ,z)
5) fin exposant

Programme pascal : Calcul xy
program exposant ;
uses wincrt ;
var x , y, i, z : integer ;
begin
write(' x = ');readln(x);
write('y =');readln(y);
z := 1;
for i := 1 to y do
z := z*x;
write (x,' exposant ',y,' = ',z);
end.

Exercice 02 :
Analyse : Vérification d'une chaine contenant des caractères majuscules
a) Analyse
Nom : majuscule
Résultat = ecrire (ʺ est ce que ch est majuscule ? ʺ ,b)
b = [i ← 1] répéter
[ ] si ch[i] dans [ʺAʺ..ʺZʺ] alors b ← vrai sinon b ← faux
fin si
jusqu'à (i > long(ch)) ou (b = faux))
ch = donnée(ʺ ch = ʺ)
fin masjuscule

b) T.D.O
Objet Nature/type
ch
var / chaine
i
var/entier
b
var/
booléen

Rôle
Chaine à vérifier
compteur
Décision de type de
caractère

Algorithme : Vérification d'une chaine contenant des caractères majuscules
0) debut majuscule
1) ecrire( ʺ ch = ʺ), lire(ch)
2) b = [i ← 1] répéter
[ ] si ch[i] dans [ʺAʺ..ʺZʺ] alors
b ← vrai
sinon b ← faux
fin si
jusqu'à (i > long(ch)) ou (b = faux))
3) ecrire (ʺ est ce que ch est majuscule ? ʺ ,b)
4) fin majuscule

Programme pascal : Vérification d'une chaine contenant des caractères majuscules
program majuscule ;
uses wincrt ;
var i : integer ; ch : string; b : boolean;
begin
write(' ch = ');readln(ch);
i := 1;
repeat
if(ch[i] in ['A'..'Z']) then b := true else b := false;
i := i + 1 ;
until ((i> length(ch)) or (b = false)) ;
write (' est ce que ch est majuscule ? ' ,b);
end.

Samedi 09 décembre 2017

Année scolaire : 2017 - 2018

Exercice 03 :
Analyse : Suppression des espaces au début d'une chaine
a) Analyse
Nom : suppressionEspaceDebut
Résultat = ecrire (ch,ʺ de longueur initiale ʺ,l,ʺ est devenue
sans espace au debut de taille ʺ, length(ch))

ch = [i ← 1, l ← long(ch)]
tant que ((i<=length(ch)) et (ch[i]=ʺ ʺ)) faire

b) T.D.O
Objet Nature/type
ch
var / chaine
i
l

efface(ch, 1 , 1)
i←i+1

var/entier
var/ entier

Rôle
Chaine à
transformer
compteur
Longueur de la
chaine

fin tant que
ch = donnée(ʺ ch = ʺ)
fin suppressionEspaceDebut

Algorithme : Suppression des espaces au début d'une chaine
0) debut suppressionEspaceDebut
1) ecrire( ʺ ch = ʺ), lire(ch)
2) ch = [i ← 1, l ← long(ch)]
tant que ((i<=length(ch)) et (ch[i]=ʺ ʺ)) faire
efface(ch,1,1)
i←i+1

fin tant que
3) ecrire (ch,ʺ de longueur initiale ʺ,l,ʺ est devenue sans espace au debut de taille ʺ, length(ch))
4) fin suppressionEspaceDebut

Programme pascal : Suppression des espaces au début d'une chaine
program suppressionEspaceDebut ;
uses wincrt ;
var
ch : string ;
i, l : integer ;
begin
write(' ch = ');readln(ch);
i := 1;
l := length(ch);
while((i<=length(ch)) and (ch[i]=' ')) do
begin
delete(ch,i,1);
i:= i + 1 ;
end;
write(ch,' de longueur initiale ',l,' est devenue sans espace au debut de taille ', length(ch));
end.

Exercice 04 :
-- Question a -Analyse : Saisie d'un entier dans [10 .. 100]
a) Analyse
Nom : saisieN
Résultat = N = [ ] répéter
N = donnée(ʺTapez un entier dans [ 10 .. 100] : ʺ)
jusqu'à ((N >= 10) et (N <= 100))
fin saisieN

Samedi 09 décembre 2017

b) T.D.O
Objet Nature/type
N
var / entier

Rôle
Entier à saisir

Année scolaire : 2017 - 2018

-- Question b -Algorithme : Saisie d'un entier > 0
0) debut saisieEntierPositif
1) N = [ ] répéter
Ecrire (ʺTapez un entier dans [ 10 .. 100] : ʺ)
Lire( N)
jusqu'à n > 0
2) fin saisieEntierPositif

Question c -Programme Pascal : Chaine contenant que des chiffres
program chaineChiffre ;
uses wincrt ;
var
ch : string ;
i, l : integer;
b : boolean ;
begin
write('Saisie de la chaine ',chr(133),' verifier ');readln(ch);
i:= 1; l := length(ch); b := false;
repeat
begin
if (ch[i]>='0') and (ch[i]<='9')) then b := true
else b := false ;
i := i + 1 ;
end ;
until ((i> l) or (b = false)) ;
if b = true then
writeln('La chaine ',ch,' contient que des chiffres')
else
writeln('La chaine ',ch,' contient des caractres autres que des chiffres') ;
end.

Exercice 05 :
-- Question a -Algorithme : Tous les diviseurs d'un entier n > 0
0) debut diviseursEntier
1) N = [ ] répéter
Ecrire (ʺTapez un entier > 0 : ʺ)
Lire( N)
jusqu'à n > 0
2) [ ] = pour i de 1 à n faire
si (n mod i = 0) alors
ecrire (i, ʺ est un diviseur de ʺ, n)
fin si
fin pour
3) fin diviseursEntier

Samedi 09 décembre 2017

Année scolaire : 2017 - 2018

-- Question b -Algorithme : Calcul PGCD de deux entiers
0) debut calculPGCD
1) ecrire(ʺ a = ʺ) , lire (a)
2) ecrire(ʺ b = ʺ), lire(b)
3) (max, min) = [max ← a, min ← b ] si a < b alors
min ← a
max ← b
fin si
4) [ z ← max - min ] tant que z <> 0 faire
max ← min
min ← z
z ← abs(max - min)
fin tantQue
3) ecrire(ʺPGCD(ʺ , a,ʺ , ʺ,b,ʺ) = ʺ , min)
4) fin calculPGCD

-- Question c -Algorithme : Somme des N entiers pairs composé par trois chiffres
0) debut sommePairs
1) [ ] répéter
N = donnée(ʺ Lecture d'entier composé par trois chiffres ʺ)
Jusqu'à n dans [100..999]
2) [ s ← 0 ]
pour i de 1 à n-1 faire
[ ] si ( n mod 2 = 0 ) alors
s←s+i
finSi
finPour
3) ecrire(ʺLa somme des entiers pairs < ʺ ,n, ʺ = ʺ, s)
4) fin sommePairs

Samedi 09 décembre 2017

Année scolaire : 2017 - 2018


Serie Support Cours.pdf - page 1/5


Serie Support Cours.pdf - page 2/5


Serie Support Cours.pdf - page 3/5

Serie Support Cours.pdf - page 4/5

Serie Support Cours.pdf - page 5/5


Télécharger le fichier (PDF)


Serie Support Cours.pdf (PDF, 220 Ko)

Télécharger
Formats alternatifs: ZIP



Documents similaires


serie support cours
serie revisioncorrection
structures repetitives
serie analyse modulaire cours
serie 1structures de donnees
serie revision corrige

Sur le même sujet..