Fichier PDF

Partage, hébergement, conversion et archivage facile de documents au format PDF

Partager un fichier Mes fichiers Convertir un fichier Boite à outils PDF Recherche PDF Aide Contact



correctionSerieCoursStructuresConditionnelles .pdf



Nom original: correctionSerieCoursStructuresConditionnelles.pdf
Titre: Serie 02
Auteur: hp

Ce document au format PDF 1.4 a été généré par PDFCreator Version 1.5.0 / GPL Ghostscript 9.05, et a été envoyé sur fichier-pdf.fr le 17/12/2017 à 16:06, depuis l'adresse IP 41.225.x.x. La présente page de téléchargement du fichier a été vue 207 fois.
Taille du document: 141 Ko (3 pages).
Confidentialité: fichier public




Télécharger le fichier (PDF)









Aperçu du document


MINISTERE EDUCATION TUNISIENNE
--- --------------------------------------------------------

SERIE Cours : Les structures
conditionnelles [ Si - Selon ]

Epreuve :
Informatique
Section :
Sciences Expérimentales
Coefficient : 1
Durée : 2 heures
Classe : 4 sciences Expérimentales 2

Exercice 01 :
Ecrire un programme qui permet d'afficher les solutions d'un polynôme de second degré.

Exercice 02 :
Ecrire un algorithme qui permet la classification des mois de l'année selon son nombre
des jours

Exercice 03 :
Ecrire un programme qui permet d'afficher le type d'un entier [Positif ou négatif ] tel que
-100 =< X <= 100.

Exercice 04 :
Ecrire une analyse qui permet la lecture d'une année et afficher son type ( Bissextile , non
Bissextile)

Exercice 05 :
Ecrire une analyse qui permet la lecture de deux réels et afficher le maximum parmi les
deux.

Exercice 06 :
Écrire un algorithme qui simule le jeu de pile ou face
Déroulement du jeu :
1. L'utilisateur saisit la lettre P pour pile, et F pour face
2. Valide sa saisie (par affichage du message « Choix Pile » dans le cas où le choix
été P

ou « Choix Face » dans le cas où été F).

3. Le programme, lui, choisit aléatoirement un nombre entre 0 et 25.
4. Si le nombre tiré au sort est pair , alors pile est gagnant, face est perdant. Si le
nombre tiré au sort est impair, alors pile est perdant et face est gagnant.
5. Le programme affiche un message : gagné ou perdu.

Samedi 14 octobre 2017

Année scolaire : 2017 - 2018

MINISTERE EDUCATION TUNISIENNE
--- --------------------------------------------------------

Correction Série Cours : Les structures
conditionnelles [Si - Selon]

Epreuve :
Informatique
Section :
Sciences Expérimentales
Durée : 2 heures
Coefficient :
1
Classe : 4 sciences Expérimentales 2

Exercice 01 :
Programme pascal : Solutions equation Second degré
program equationSecondDegre ;
uses wincrt;
var
a , b , c , delta : real;
begin
write('a = '); readln(a);
write('b = '); readln(b);
write('c = '); readln(c);
writeln('L'' equation a ');
delta := sqr(b) - 4 * a * c;
if delta < 0 then ch ← 'a deux solutions'
else
if delta > 0 then ch ← 'a une solution '
else
ch ← 'n''a pas de solutions' ;
write('L''equation ', ch);
end.

Exercice 02 :
Algorithme : Classification des mois selon le nombre des jours
0) debut classificationMois
1) ch = [ Ecrire('Ordre du mois = '), lire(mois)]
selon mois faire
1,3,5,7,8,10,12 : ch ← " parmi les mois ayant 31 jours "
2 : [Ecrire ( ' Annee = '), lire(an) ] si (an mod 4 = 0) et (an mod 100 <> 0) alors
ch ← " mois fevrier ayant 29 jours cette annee"
sinon ch ← " mois fevrier ayant 28 jours cette annee"
finSi
4,6,11 : ch ← " parmi les mois ayant 30 jours "
sinon
ch ← " est un ordre de mois saisi non valide "
finSelon
2) Ecrire (mois,ch)
3) fin classificationMois

Exercice 03 :
Programme pascal : Type entier positif ou négatif
program positifNegatif ;
uses wincrt;
var n : shortint ;
begin
write('N = '); readln(n);
if n < 0 then
ch:= 'est un entier négatif'
else
ch := 'est un entier positif' ;
write(n, ch);
end.
Samedi 14 octobre 2017

Année scolaire : 2017 - 2018

Exercice 04 :
Analyse : Type année saisie ( bissextile ou non )
Une année est bissextile si elle est divisible par 4 et non divisible par 100
a) Analyse
Nom : bissextile
Résultat = ecrire (an, typeAn)
typeAn = [an = donnée("Année = ") ]
si (an mod 4 = 0) et (an mod 100 <> 0) alors
typeAn ← " est bissextile "
sinon
typeAn ← " n''est pas bissextile "
finSi
fin bissextile

b) T.D.O
O
an

N/T
var / entier

R
Année saisie

typeAn

var/chaine

Chaine ayant
le type
d'année saisie

Exercice 05 :
Analyse : Lecture deux réels et affichage du maximum
a) Analyse
Nom : maximum
Résultat = ecrire (maxi)
maxi = [ r1 = donnée("entrer premier reel
si (r1 > r2) alors
maxi ← r1
sinon
maxi ← r2
finSi
fin maximum

b) T.D.O
O
") ,r2 = donnée("entrer deuxième reel ")

]

r1

N/T
var / réel

R
1er réel saisi

r2

var/réel

maxi

Var/réel

2ème réel
saisi
Maximum des
deux réels

Exercice 06 :
Algorithme : Jeu Pile ou Face
0) debut jeuPileFace
1) validation = [Ecrire ( ' Saisissez P pour Pile et F pour Face ') , lire (pf) ]
si pf = 'P' alors validation ← 'Choix Pile'
sinon validation ←' Choix Face '
finSi
2) result = [ n ← alea(26) ] si n mod 2 = 0 alors
result ←' Pile est gagnant et Face perdant'
sinon
result ←'Face est gagnant et Pile perdant'
finSi
3) decisionJeu = [posPileG ← pos('Pile est gagnant',result), posFaceG ← pos('Face est gagnant',result)]
si (pf = 'P' et posPileG <> 0) ou (pf = 'F' et posFaceG<> 0 ) alors
decisionJeu ← 'Gagné'
sinon
decisionJeu ←'Perdu'
finSi
4) fin jeuPileFace

Samedi 14 octobre 2017

Année scolaire : 2017 - 2018


correctionSerieCoursStructuresConditionnelles.pdf - page 1/3
correctionSerieCoursStructuresConditionnelles.pdf - page 2/3
correctionSerieCoursStructuresConditionnelles.pdf - page 3/3

Documents similaires


correctionseriecoursstructuresconditionnelles
support1
serie d exercices de n 1 informatique bac sciences exp 2010 2011 mr ayadi
corrigeseance0
suite td2 1 ere
solution examen s4 science economique


Sur le même sujet..