Serie Revision Corrige .pdf


Nom original: Serie Revision Corrige.pdfTitre: Serie RevisionAuteur: hp

Ce document au format PDF 1.4 a été généré par PDFCreator Version 1.5.0 / GPL Ghostscript 9.05, et a été envoyé sur fichier-pdf.fr le 08/01/2018 à 11:01, depuis l'adresse IP 41.224.x.x. La présente page de téléchargement du fichier a été vue 228 fois.
Taille du document: 155 Ko (3 pages).
Confidentialité: fichier public


Aperçu du document


MINISTERE EDUCATION TUNISIENNE
--- --------------------------------------------------------

SERIE : Les structures conditionnelles
[Révision]

Epreuve :
Informatique
Section :
Sciences Expérimentales
Durée : 2 heures
Coefficient :
1
Classe : 4 sciences Expérimentales 2

Exercice 01 :
Exercice 02 :
Traduire l'algorithme suivant en une analyse
et un programme Pascal
0) Début Inconnu
1) Ecrire ( " Tapez un caractère : " ) , Lire ( c1 )
2) c2 = [ ] Si ( ORD ( c1) >= 97 ) et ( ORD(c1) <= 122 )
alors c2 ← CHR ( ORD( c1 ) - 32 )
sinon

c2 ← c1

Ecrire une analyse qui permet de déterminer
la mention d'un étudiant par la formule
suivante :
Moyenne < 10 : Refuse(e)
10 <= Moyenne <= 15 : Admis(e) avec mention Bien
15 < Moyenne <= 20 : Admis(e) avec mention Très Bien

fin si

3) Ecrire ( c2 )
4) Fin Inconnu

Exercice 03 :
Ecrire
un
algorithme
permettant
détermination de la parité d'un entier saisi

Exercice 04 :

la

Ecrire un programme nommé Resistance,
qui saisi les valeurs des résistances R1 , R2
, R3 , R4 puis affiche la résistance
équivalente RE du circuit. On rappelle que :
La résistance équivalente de 2 ou plusieurs
résistances montées en série est leur somme

R1
R3

R4

R2

La résistance équivalente de 2 ou plusieurs
montées en parallèle a un inverse égal à la
somme des inverses

Exercice 05 :
Ecrire une analyse qui permet de saisir le sexe ( F / M ) , la taille ( cm ) et le poids ( kg ) d'une
personne et d'afficher :
1. PI , le poids idéal d'une personne , sachant que ce poids théorique est donné par la formule de Lorenz
comme suit :
• Pour un homme : PI = ((taille - 100) - ( taille - 150)) / 4
• Pour une femme : PI = ((taille - 100) - ( taille - 120)) / 4
2

3

2. BMI, l'indicateur d'obésité ( Body Mass Index ) où BMI = poids / taille avec taille en mètre

3. L'état de la personne concernée : Normale dans le cas où MBI <= 27 , ou Obèse dans le cas où BMI > 27 ou
Malade dans le cas où BMI >= 32

Par exemple :
Sexe

Taille

Poids

PI

BMI

ETAT

M

180

78

12.5

0.002

Normale

Samedi 25 novembre 2017

Année scolaire : 2017 - 2018

MINISTERE EDUCATION TUNISIENNE
--- --------------------------------------------------------

Corrigé SERIE : Les structures
conditionnelles [Révision]

Epreuve :
Informatique
Section :
Sciences Expérimentales
Durée : 2 heures
Coefficient :
1
Classe : 4 sciences Expérimentales 2

Exercice 01
Analyse : Conversion en majuscule
a) Analyse
Nom : inconnu
Résultat = Ecrire ( c2 )
c2 = [ c1 = donnée(ʺ Tapez un caractère : ʺ) ]
SI (ORD(c1) >= 97) et (ORD(c1)<=122) alors
c2 ← CHR(ORD(c1)-32)
sinon c2 ← c1
finSI
Fin inconnu

b) T.D.O
Objet
Nature/type
c1,c2 var / caractère

Rôle
Caractère c1 à
convertir en
majuscule dans
c2

Programme pascal : Conversion en majuscule
program inconnu ;
uses wincrt ;
var c1, c2 : char ;
begin
write(' Tapez un caractère : ');readln(c1);
if (ord(c1)>=97) and (ord(c1)<=122) then c2 := chr(ord(c1)-32) else c2 := c1 ;
write (c2);
end.

Exercice 02
Analyse : Attribution mention à un élève
a) Analyse
Nom : mentionEleve
Résultat = Ecrire ( "L''élève ayant ",moy," a la mention , m)
m = [ moy = donnée("Introduire la moyenne : ") ]
SI (moy < 10) alors
m ← " Refusé(e)"
sinon

b) T.D.O
Objet
Nature/type
moy var / réel
m

Var/chaine[10]

Rôle
Moyenne de
l'élève
Mention de
l'élève attribuée

SI (moy >= 10)and (moy <+ 15) alors
m ← " Bien"
sinon
m ← " Très bien "
finSi

finSI
Fin mentionEleve

Exercice 03
Algorithme : Parité d'un entier saisi
0) debut parite_Entier
1) decision = [ Ecrire(" Entier un entier : "), lire ( n ) ]
SI (n>= 0) alors
decision ← concat(n," est un entier positif")
sinon
decision ← concat(n," est un entier négatif")
finSI
2) Ecrire(decision)
3) Fin parite_Entier
Samedi 25 novembre 2017

Année scolaire : 2017 - 2018

Exercice 04
Programme : Calcul résistance
program resistance ;
uses wincrt ;
var r1 , r2 , r3 , r4 , re : real ;
begin
write('Entrez la valeur de la resistance r1 : ');readln(r1);
write('Entrez la valeur de la resistance r2 : ');readln(r2);
write('Entrez la valeur de la resistance r3 : ');readln(r3);
write('Entrez la valeur de la resistance r4 : ');readln(r4);
re := 1/(1/r1 + 1/r2) + r3 + r4 ;
writeln(' La resistance totale egale a : ',re);
end.

Exercice 05
Analyse : affichage des analyses de santé d'un être humain
a) Analyse : méthode 1
Nom : resultatAnalyse
Résultat = Ecrire ( "Les résultats sont : ",pi," ",bmi," ",etat)
pi = [ sexe = donnée, taille = donnée ]
SI (sexe = "h") alors
pi ← ((taille - 100) - (taille-150))/4
finSi
SI (sexe = "f") alors
pi ← ((taille - 100) - (taille-120))/4
finSI
etat = [ bmi ← poids / carre(taille) ]
SI (bmi <= 27) alors
etat ← "Normale"
sinon

c) T.D.O
Objet
Nature/type
taille réel
poids réel
pi
bmi

réel
réel

etat

chaine

Rôle
Taille de la
personne
Poids de la
personne
Poids idéal
Indicateur
d'obésité
Etat de la
personne

SI (bmi > 27) et (bmi <32) alors
etat ← "Obèse"
sinon
etat ← "Malade"

finSI
poids = donnée
Fin resultatAnalyse
b) Analyse : Méthode 2
Nom : resultatAnalyse
Résultat = Ecrire ( "Les résultats sont : ",pi," ",bmi," ",etat)
pi = [ sexe = donnée, taille = donnée ]
selon sexe faire
"h" : pi ← ((taille - 100) - (taille-150))/4
"f" : pi ← ((taille - 100) - (taille-120))/4
sinon pi ← 0
finSelon
etat = [ bmi ← poids / carre(taille) ]
SI (bmi <= 27) alors
etat ← "Normale"
sinon
SI (bmi > 27) et (bmi <32) alors
etat ← "Obèse"
sinon
etat ← "Malade"

finSI
poids = donnée
Fin resultatAnalyse
Samedi 25 novembre 2017

Année scolaire : 2017 - 2018


Serie Revision Corrige.pdf - page 1/3


Serie Revision Corrige.pdf - page 2/3


Serie Revision Corrige.pdf - page 3/3


Télécharger le fichier (PDF)


Serie Revision Corrige.pdf (PDF, 155 Ko)

Télécharger
Formats alternatifs: ZIP



Documents similaires


serie revision corrige
serie revisioncorrection
serie revision
enonce serie revision 1
fiche2 ex if case
serie support cours

Sur le même sujet..