Serie RevisionCorrection .pdf



Nom original: Serie RevisionCorrection.pdfTitre: Serie RevisionAuteur: hp

Ce document au format PDF 1.4 a été généré par PDFCreator Version 1.5.0 / GPL Ghostscript 9.05, et a été envoyé sur fichier-pdf.fr le 13/01/2018 à 20:35, depuis l'adresse IP 197.27.x.x. La présente page de téléchargement du fichier a été vue 661 fois.
Taille du document: 241 Ko (6 pages).
Confidentialité: fichier public


Aperçu du document


MINISTERE EDUCATION TUNISIENNE
--- --------------------------------------------------------

SERIE 03 : Les structures Répétitives
[Révision]

Epreuve :
Informatique
Section :
Sciences Expérimentales
Durée : 2 heures
Coefficient :
1
Classe : 4 sciences Expérimentales 2

Exercice 01 :
Ecrire un algorithme et un programme pascal intitulé occurrence qui permet de saisir une
chaine de caractères ch composée par 10 caractères puis afficher l'occurrence(nombre) des
voyelles qui figure dans la chaine ch. La recherche ne fait pas une distinction entre les
majuscules et les minuscules.

Exercice 02 :
Ecrire un algorithme qui permet le dessin d'un triangle plein isocèle de hauteur n tel que
2<=n<=10. Par exemple n = 5

Exercice 03 :
Ecrire programme pascal qui permet la saisie d'un entier n ( 5 <= n<= 20) puis la saisie de n
entiers choisi aléatoirement composés au maximum par 3 chiffres à mettre dans un tableau A
d'un, puis le calcul et l'affichage la moyenne arithmétique m des éléments de A aussi leur
écart

type

S

tel

que

:

Exercice 04 :
a) Ecrire une analyse qui définit l'existence d'un caractère donné dans une chaine
b) Ecrire un algorithme permettant la saisie d'une chaine ayant des caractères minuscules

Exercice 05 :
Ecrire une analyse, un algorithme puis un programme pascal intitulé sommeCarresImpairs qui
permet le calcul de la somme des carrés des n premiers entiers impairs.
Par exemple n = 5 alors 12+32+52+72+92 = 165

Samedi 16 décembre 2017

Année scolaire : 2017 - 2018

Exercice 06 :
Un jeu consiste à choisir un nombre au hasard et le faire deviner à l'adversaire en lui disant "Plus
grand" ou "Plus petit ". Ecrire un programme qui permet à un utilisateur de deviner le nombre en
indiquant le nombre de tentatives pour le trouver . Les étapes du jeu sont comme suit
a) Un nombre entre 1 et 100 choisi par l'ordinateur
b) Le joueur commence à proposer le nombre choisi
c) Si le nombre proposé est supérieur du celui choisi, le message "Plus grand" est affiché , sinon le
message "Plus petit" est affiché et le nombre de tentatives est mis à 1 , etc.

Exercice 07 :
a) Ecrire une analyse qui permet la saisie d'un entier n strictement positif
b) Ecrire une analyse qui rempli d'un tableau T de n entiers compris entre [0..30]
c) Ecrire un algorithme qui permet la création de deux chaines intégrant les entiers pairs
(respectivement impairs) à la fin de la chaine chp(respectivement chi) tel que chp contient
initialement la chaine "Pairs" et chi la chaine "Impairs"
d) Ecrire un programme pascal qui présente la traduction pascal de les analyses et
l'algorithme précédents en ordre(a,b,c) . Le programme affichera les chaines résultats chp
et chi.

Exercice 8 :
On dispose de deux tableaux T1 et T2 contenant respectivement n et m entier avec m < n.
Les éléments de T1 sont des entiers composés par 2 chiffres aléatoirement et ceux de T2 sont
des chiffres de 0 à 9 choisi aléatoirement. On désire chercher dans T2 tous les diviseurs d'un
élément donné de position p dans le tableau T1.
Exemple :

T1 23

15

10

277

T2 3

6

5

1

300

34

p=2

Résultat à afficher :

3 , 5 , 1 sont les diviseurs de 15

Ecrire une analyse traduite en un algorithme qui permet de saisir les deux tableaux T1 et T2 et
l'indice d'un élément p de T1 puis afficher à l'écran tous les diviseurs de T[p] figurant dans T

Samedi 16 décembre 2017

Année scolaire : 2017 - 2018

MINISTERE EDUCATION TUNISIENNE
--- --------------------------------------------------------

Correction : Les structures Répétitives
[Révision]

Epreuve :
Informatique
Section :
Sciences Expérimentales
Durée : 2 heures
Coefficient :
1
Classe : 4 sciences Expérimentales 2

Exercice 01 :
Algorithme : Occurrences des voyelles dans une chaine de caractères
0) debut occurrence
1) ch = [ ] répéter
ecrire( ʺSaisie d''une chaine de 10 caracteres : ʺ) , lire (ch)
jusqu'à long(ch) = 10
2) nbO = [ nbO ← 0 ]
pour i de 1 à 10 faire
[ch[i] ← majus(ch[i]) ] si (ch[i] dans [ "A","E","I","O","U","Y"]) alors
nbO ← nbO +1
finSi
finPour
3) ecrire (ʺLe nombre d''occurrences des voyelles est : ʺ ,nbO)
4) fin occurrence

Programme pascal : Occurrences des voyelles dans une chaine de caractères
program occurrence ;
uses wincrt ;
var ch :string; i,nbO : integer;
begin
repeat
begin
write('Saisie d''une chaine de 10 caracteres // Ch = '); readln(ch);
end;
until length(ch)=10 ;
nbO:= 0;
for i :=1 to 10 do
begin
ch[i]:=upcase(ch[i]);
if(ch[i]in['A','E','I','O','U','Y'])then nbO := nbO + 1;
end ;
write('Le nombre d''occurrences des voyelles est : ',nbO);
end.

Exercice 02 :
Algorithme : Dessin triangle Plein Isocèle
0) debut dessin_Triangle_Isocele
1) n = [ ] répéter
ecrire( ʺHauteur du triangle à dessiner ʺ) , lire (n)
jusqu'à (n>= 2) et (n <= 10)
2) affichage = [ ] pour i de 1 à n faire
nbEspaces ← n - i + 1
nbEtoiles ← 2*i - 1
[ ] = pour j de 1 à nbEspaces faire
ecrire(" ")
finPour
[ ] = pour j de 1 à nbEtoiles faire
ecrire("*")
finPour
ecrire(" ")
finPour
3) fin dessin_Triangle_Isocele
Samedi 16 décembre 2017

Année scolaire : 2017 - 2018

Exercice 03 :
Programme : Moyenne arithmétique et écart type
program moyenne_ecart ;
uses wincrt;
type tab = array[1..100] of integer ;
var n,i : integer ; a :tab; m,s : real;
begin
repeat
begin
write(' N = ');readln(n);
end ;
until n in [5..20];
randomize ;
for i := 1 to n do a[i] := random(1000);
m := 0;
for i :=1 to n do m := m + a[i];
m := m/n;
s := 0;
for i := 1 to n do s := s + sqr(a[i]-m);
write('Moyenne = ',m:7:3,' Ecart type = ',s:7:3);
end.

Exercice 04 :
a) Ecrire une analyse qui définit l'existence d'un caractère donné dans une chaine
Analyse : Existence d'un caractère dans une chaine
a) Analyse
Nom : existenceCaractere
Résultat = ecrire (ʺLe caractère ʺ,c,ʺ ʺ, decision)
decision = [ ] si b = vrai alors
decision ← " est existant"
sinon
decision ←"n''est pas existant"
finSi
b = [ i ← 1] répéter
[ ] = si ch[i] = c alors
b ← vrai
sinon
i←i+1
finSi
jusqu'à (i > long(ch)) ou (b = vrai)
c = donnée(" caractère à chercher ")
ch = donnée(ʺ ch = ʺ)
fin existenceCaractere

b) T.D.O
Objet
ch
i
c

Nature/type
var / chaine
var/entier
var/ caractère

b

var/booléen

decision var/booléen

Rôle
Chaine à vérifier
compteur
Caractère à
vérifier
Existence ou
non du
caractère
Décision
d'existence du
caractère

b) Ecrire un algorithme permettant la saisie d'une chaine ayant des caractères minuscules
Algorithme : Saisie d'une chaine ayant des caractères minuscules
0) debut minuscule
1) ch = [ ] répéter
[ Ecrire("CH = ") , lire(ch) , i ← 1 , b ← faux ] répéter
b= [ ] si (ch[i] dans ["a".."z"]) alors b ← vrai
sinon b ← faux
i ← i+1
finSi
jusqu'à (b = faux) ou (i > long(ch))
jusqu'à b = vrai
2) fin minuscule
Samedi 16 décembre 2017

Année scolaire : 2017 - 2018

Exercice 05 :
Ecrire une analyse, un algorithme puis un programme pascal intitulé sommeCarresImpairs qui
permet le calcul de la somme des carrés des n premiers entiers impairs.
Par exemple n = 5 alors 12+32+52+72+92 = 165
Analyse : Calcul des carrés des n premiers entiers impairs
a) Analyse
Nom : somme
Résultat = Ecrire (ʺLa somme résultat est : ʺ,s)
s = [ s ← 0 ] pour i de 1 à n faire
[ ] = si i mod 2 <> 0 alors
s ← s + carré(i)
finSi
finPour
n = donnée("N = ")
fin somme

b) T.D.O
Objet
n

Nature/type
var / entier

i
s

var/entier
var/ entier

Rôle
Chiffre à
calculer la
somme de ces
premiers carrés
impairs
compteur
Somme calculée

Algorithme : Calcul des carrés des n premiers entiers impairs
0) debut somme
1) Ecrire(" N = ") , lire(n)
2) s = [ s ← 0 ] pour i de 1 à n faire
[ ] = si i mod 2 <> 0 alors
s ← s + carré(i)
finSi
finPour
3)Ecrire("La somme résultat est : ",s)
4)fin somme

Programme pascal : Calcul des carrés des n premiers entiers impairs
program somme ;
uses wincrt ;
var
i, s , n : integer ;
begin
write('N = '); readln(n);
s := 0 ;
for i := 1 to n do
if i mod 2 <> 0 then
s := s + sqr(i);
write('La somme résultat est : ', s);
end.

Exercice 06 :
Programme : Jeu
program jeu ;
uses wincrt ;
var n,pr,i : integer ;
begin
randomize ; n := 1 + random(101); i:= 1;
repeat
begin
write('Proposition ',i,' : ');readln(pr);
if(pr<n)then writeln('entier est plus grand que ',pr)
else writeln('entier est plus petit que ',pr) ;
i := i+1;
end;
until pr = n ;
writeln('Vous avez trouvez l''entier ',n,' après ',i,' tentatives');
end.
Samedi 16 décembre 2017

Année scolaire : 2017 - 2018

Exercice 07 :
a) Ecrire une analyse qui permet la saisie d'un entier n strictement positif
Analyse : Saisie d'un entier strictement positif
a) Analyse
Nom : entierPositif
Résultat = n = [ ] repeat
n = donnée("N = ")
until n > 0
fin entierPositif

b) T.D.O
Objet

Nature/type
var / entier

n

Rôle
Entier >0

b) Ecrire une analyse qui rempli d'un tableau T de n entiers compris entre [0..30]
Analyse : Remplissage d'un tableau de n entiers pairs
a) Analyse
Nom : remplissage
Résultat = T = [ ] pour i de 1 à n faire
T[i] = [ ] repeat
T[i] = donnée("Entrer T[",i,"] = ")
until T[i] >= 0 et T[i] <= 30
finPour
fin remplissage

b) T.D.N.T
Types
Tab = tableau de 100 entiers
c) T.D.O
Objet Nature/type
n
var / entier
i
Var / entier
T
Var/tab

Rôle
Taille du tableau
compteur
Tableau à remplir

c) Ecrire un algorithme qui permet la création de deux chaines intégrant les entiers pairs
(respectivement impairs) à la fin de la chaine chp(respectivement chi) tel que chp contient
initialement la chaine "Pairs" et chi la chaine "Impairs"
Algorithme : Calcul de la racine carré de la somme des entiers dans la variable x
0) debut chaines
1) (chp,chi) = [ chp ←"Pairs",chi ←"Impairs" ] pour i de 1 à n faire
[ convch(T[i],c) ] si (t[i] mod 2 <> 0 ) alors insère(c,chi,long(chi)+1)
sinon insère(c,chp,long(chp)+1)
finSi
2) Ecrire(chp," ",chi)
3) fin chaines

d) Ecrire un programme pascal qui présente la traduction pascal de les analyses et l'algorithme
précédents en ordre(a,b,c) . Le programme affichera les chaines résultats chp et chi
Programme pascal : traduction des analyses et de l'algorithme précédents
program exercice7 ;
uses wincrt ;
type tab = array[1..100]of integer;
var t: tab ; i,n : integer; c,chp,chi : string;
begin
repeat
begin
write('N = ');readln(n);
end;
until n>0;
for i := 1 to n do
repeat begin
write('Entrer T[',i,'] = ');
readln(t[i]);
end;
until (t[i]>= 0) and (t[i] <=30);
Samedi 16 décembre 2017

chi := 'Impairs';chp :='Pairs';
for i := 1 to n do
begin
str(t[i],c);
if(t[i] mod 2 <>0)then
insert(c,chi,length(chi)+1)
else
insert(c,chp,length(chp)+1)
end;
write(chp, '
',chi);
end.

Année scolaire : 2017 - 2018


Serie RevisionCorrection.pdf - page 1/6
 
Serie RevisionCorrection.pdf - page 2/6
Serie RevisionCorrection.pdf - page 3/6
Serie RevisionCorrection.pdf - page 4/6
Serie RevisionCorrection.pdf - page 5/6
Serie RevisionCorrection.pdf - page 6/6
 




Télécharger le fichier (PDF)


Serie RevisionCorrection.pdf (PDF, 241 Ko)

Télécharger
Formats alternatifs: ZIP



Documents similaires


serie revisioncorrection
serie support cours
structures repetitives
correctionseriecoursstructuresconditionnelles
fiche3 ex iterative1
enonce serie revision

Sur le même sujet..