bac2014séance8h .pdf


Nom original: bac2014séance8h.pdf
Titre: bac2014séance8h
Auteur: hp

Ce document au format PDF 1.4 a été généré par PDFCreator Version 1.5.0 / GPL Ghostscript 9.05, et a été envoyé sur fichier-pdf.fr le 10/03/2018 à 22:26, depuis l'adresse IP 197.27.x.x. La présente page de téléchargement du fichier a été vue 417 fois.
Taille du document: 125 Ko (2 pages).
Confidentialité: fichier public


Aperçu du document


MINISTERE EDUCATION TUNISIENNE
--- --------------------------------------------------------

Correction BAC 2014 séance 8h

Epreuve :
Informatique
Section :
Sciences Expérimentales
Durée : 1 heure
Coefficient :
1
Classe : 4 sciences Expérimentales 2

-- Analyse du programme principal --

Analyse : programme principal
a) Analyse
Nom : exerciceBac2014_8h
Résultat = PROC affiche(n , m)
(n,m) = PROC saisie( n , m )
Fin exerciceBac2014

b) T.D.O.G
Objet
n
m
saisie
affiche

Nature/type
var / entier
var/ entier
procédure
procédure

-- Algorithmes des modules --

Algorithme : Procédure saisie
0) Def PROC saisie( var n, m :entier)
1) répéter
Ecrire(" N = ")
Lire( n )
Ecrire(" M = ")
Lire( m )
jusqu'à (n >= 100) et (n < m)
2) Fin PROC saisie

Algorithme : Procédure affiche
0) Def PROC affiche( n , m : entier )
1) pour i de n à m faire
[h ← harshad(i) , p ← premier(i-1)]
si (h = vrai) et (p = vrai) alors
Ecrire(i," car ",i," est harshad et son predecesseur ",i-1," est un entier premier")
finSi
2) Fin PROC affiche

Algorithme : Fonction harshad
0) Def FN harshad( x : entier ) : booléen
1) [ convch(x,ch), s ← 0 ] pour i de 1 à long(ch) faire
valeur(ch[i],d,e)
s ←s + d
finPour
2) si x mod s = 0 alors b ←vrai
sinon b ←faux
finSi
3) harshad ← b
4)Fin harshad

Algorithme : Fonction premier
0) Def FN premier( x : entier ) : booléen
1) [ nbd ← 0 ] pour i de 1 à x faire
si x mod i = 0 alors nbd ←nbd + 1 finSi
finPour
2) si nbd = 2 alors b ←vrai
sinon b ←faux
finSi
3) premier ← b
4) Fin premier
Proposé le Samedi 10 Mars 2018

Année scolaire : 2017 - 2018

-- Programme pascal demandé --

Programme pascal : exerciceBac2014_8h
program exerciceBac2014_8h ;
uses wincrt ;
var n , m : integer ;
{----- procédure de saise de n et m tel que 100<=n<m -----}
procedure saisie ( var n , m : integer );
begin
repeat
begin
write('N = ');readln(n);
write('M = ');readln(m);
end;
until (n>=100) and (n < m) ;
end;
{----- fonction vérifie si x est un entier harshad -----}
function harshad( x : integer):boolean ;
var
b : boolean ; ch : string ;i,s,d,e : integer ;
begin
str(x,ch); s := 0 ;
for i := 1 to length(ch) do
begin
val(ch[i],d,e);
s := s + d;
end;
if x mod s = 0 then b := true
else b := false ;
harshad := b ;
end;
{----- fonction vérifie si x est un entier premier -----}
function premier ( x : integer ) : boolean ;
var
b : boolean ; i,nbd : integer ;
begin
nbd := 0 ;
for i := 1 to x do
if x mod i = 0 then nbd := nbd + 1 ;
if nbd = 2 then b := true
else b := false ;
premier := b ;
end;
{----- procédure d'affichage des entiers harshad
avec leur prédécesseurs est premier de n à m -----}
procedure affiche(n , m : integer);
var
i : integer ; h,p : boolean ;
begin
for i := n to m do
begin
h := harshad(i);
p := premier(i-1);
if (h = true) and (p = true) then
writeln(i,' car est Harshad et son predecesseur ',i-1,' est un nombre premier');
end;
end;
begin
saisie(n,m);
affiche(n,m);
end.

Proposé le Samedi 10 Mars 2018

Année scolaire : 2017 - 2018


Aperçu du document bac2014séance8h.pdf - page 1/2

Aperçu du document bac2014séance8h.pdf - page 2/2




Télécharger le fichier (PDF)




Sur le même sujet..





Ce fichier a été mis en ligne par un utilisateur du site. Identifiant unique du document: 00579424.
⚠️  Signaler un contenu illicite
Pour plus d'informations sur notre politique de lutte contre la diffusion illicite de contenus protégés par droit d'auteur, consultez notre page dédiée.