bac2018PratiqueTheorique .pdf



Nom original: bac2018PratiqueTheorique.pdf
Titre: bac2018PratiqueTheorique
Auteur: hp

Ce document au format PDF 1.4 a été généré par PDFCreator Version 1.5.0 / GPL Ghostscript 9.05, et a été envoyé sur fichier-pdf.fr le 25/05/2018 à 00:02, depuis l'adresse IP 196.229.x.x. La présente page de téléchargement du fichier a été vue 240 fois.
Taille du document: 149 Ko (3 pages).
Confidentialité: fichier public


Aperçu du document


MINISTERE EDUCATION TUNISIENNE
--- --------------------------------------------------------

Proposition correction Bac Pratique
2018

Epreuve :
Informatique
Section :
Sciences Expérimentales
Durée : 1 heure
Coefficient :
1
Classe : 4 sciences Expérimentales 2

Analyse principal :
T.D.N.T :
Tab = tableau [1..100] de chaine
Nom : achat
caractères
Résultat =[Nbp ← FN nombreProduit(N)]
T.D.O.G
Si Nbp = 0 alors
Objet
Type/nature
Rôle
Ecrire(ʺNous invitons à la consomation des produits
N
Var/entier
Nombre
ECOLOʺ)
de
sinon
produits
si Nbp>5 alors
achetés
Ecrire(ʺNous invitons à devenir l''ambassadeur
de la marqueʺ)
Nbp
Var/entier
Nombre
sinon
de
Ecrire(ʺMerci pour l''achat de ',Nbp,' produit(s) de la
produits
marque ECOLO")
d'une
finSi
marque
finSi
nombreProduit Fonction/entier Fonction
Répéter
retourne
N=Donnée (ʺDonner le nombre de produits
le
achetés: ʺ)
nombre
Jusqu'à N dans [5..100]
de
Fin achat
produits
distincts
d'une
marque

Algorithme de la fonction nombreProduit
0)DEF FN nombreProduit(N:entier):entier
1) [Nbp ← 0 , j ← 0 ]
Pour ide 1 à N faire
répéter
Ecrire(ʺDonner le nom du produit: ʺ )
lire(Nomp)
jusqu'à FN Valide(Nomp)
si (Pos('ECOLO',Nomp)<>0) et (FN verif(Nomp,T,j)=faux) alors
Nbp ← Nbp+1
J ← j+1
T[j] ← Nomp
finSi
finPour
2) nombreProduit ← Nbp
3) fin nombreProduit
Proposé le Jeudi 24 Mai 2018

T.D.O.L
Objet Type/nature Rôle
nbP
Var/entier
Nombre
de
produits
calculés
i
Var/entier
compteur
j
Var/entier
compteur
T
Var/tab
tableau

Année scolaire : 2017 - 2018

Algorithme de la fonction valide
0)Début FN valide(ch:chaine):booléen;
1)[ i ← 1 ]
Tant que (majus(ch[i]) dans ['A'..'Z','0'..'9',' ']) et (i<long(ch)) faire
i ← i+1
fin Tant que
2) si (Length(ch)<=20) and (upcase(ch[i]) in ['A'..'Z','0'..'9',' '])
alors
valide ← vrai
sinon
valide ← faux
finSi
3) fin valide

T.D.O.L
Objet Type/nature Rôle
i
Var/entier
compteur

Algorithme de la fonction verif
0)Début FN verif(ch:chaine ;T:Tab;N:entier):booléen
1) [ i ← 0 ]
répéter
i ← i+1
jusqu'à (T[i]=ch) ou (i=N)
2) si T[i]=ch alors verif ← vrai
Sinon
Verif ← faux
FinSi
3) fin verif

T.D.O.L
Objet Type/nature Rôle
i
Var/entier
compteur

Programme Pascal
Program Achat;
Uses wincrt;
Type TAB=Array[1..100] of string;
Var
N,Nbp:Integer;
function valide(ch:string):boolean;
var i:integer;
Begin
i:=1;
while(upcase(ch[i]) in ['A'..'Z','0'..'9',' ']) and (i<length(ch)) Do
i:=i+1;
if (Length(ch)<=20) and (upcase(ch[i]) in ['A'..'Z','0'..'9',' ']) then valide := true
else valide := false ;
End;
function verif(ch:string;T:Tab;N:Integer):boolean;
var i:integer;
Begin
i:=0;
Repeat
i:=i+1;
Until (T[i]=ch) or (i=N);
If T[i] = ch then
verif := true
Proposé le Jeudi 24 Mai 2018

Année scolaire : 2017 - 2018

else
verif := false ;
End;
function NombreProduit(N:integer):integer;
Var Nbp,i,j:integer;
Nomp:String;
T:TAB;
Begin
Nbp:=0;
j:=0;
for i:=1 to N do
Begin
Repeat
write('Donner le nom du produit: ' );
Readln(Nomp);
Until Valide(Nomp);
if (Pos('ECOLO',Nomp)<>0) and (verif(Nomp,T,j)=false) then
Begin
Nbp:=Nbp+1;
j:=j+1;
T[j]:= Nomp;
end;
end;
NombreProduit:=Nbp;
end;
Begin
Repeat
write('Donner le nombre de produits achetés: ' );
Readln(N);
Until N in [5..100];
Nbp:=NombreProduit(N);
if Nbp = 0 Then
write('Nous invitons à la consomation des produits ECOLO')
else if Nbp>5 then
write('Nous invitons à devenir l''ambassadeur de la marque')
Else
write('Merci pour l''achat de ',Nbp,' produit(s) de la marque ECOLO');
End.

Proposé le Jeudi 24 Mai 2018

Année scolaire : 2017 - 2018


bac2018PratiqueTheorique.pdf - page 1/3
bac2018PratiqueTheorique.pdf - page 2/3
bac2018PratiqueTheorique.pdf - page 3/3


Télécharger le fichier (PDF)

bac2018PratiqueTheorique.pdf (PDF, 149 Ko)

Télécharger
Formats alternatifs: ZIP







Documents similaires


sousprogrammes utiles
sousprogrammes utiles
program bac blanc2016
proposition correction bac2013 09h30
proposition correction bac2011 14h30
bac2018pratiquetheorique