fiche2 ex if case .pdf


Nom original: fiche2-ex-if-case.pdfAuteur: Kiteb.net

Ce document au format PDF 1.4 a été généré par Writer / LibreOffice 4.0, et a été envoyé sur fichier-pdf.fr le 26/02/2020 à 17:19, depuis l'adresse IP 196.235.x.x. La présente page de téléchargement du fichier a été vue 46 fois.
Taille du document: 107 Ko (1 page).
Confidentialité: fichier public

Aperçu du document


Devoirs et examens sur : www.Kiteb.net

Structures de contrôle conditionnelles – Fiche 1
Exercice1 :
Exercice
2:
Écrire
un
programme qui permet de Exercice 3 :
Écrire un programme qui permet de saisir
saisir
une
moyenne
(moy)
puis affiche la décision:
un temps (heure et minute) lui ajoute
Écrire un programme qui permet de faire la
ADMIS Si moy >=10
5minutes puis l'affiche.
résolution de l’équation du 1er degré :
CONTROLE
Si 9<=moy <10
Exemples :
ax+b = 0
REDOUBLE
Si moy<9
heure : 10
heure : 10
heure : 23
1)
Pré-analyse
:
Pré-analyse :But : afficher la décision
minute : 20
minute:57
minute:55
But :Afficher la solution
Données : moy
Formules : structure si sur moy
donne : 10:25 donne: 11: 02 donne: 00:00
données : a, b
Analyse :
Formules :
Algorithme :
Nom:Décision
2) Analyse :
0) Début plus5min
Résultat= Ecrire(message)
Nom : Équation
1) Ecrire(''Heure: ''),lire(hh)
message=[]si moy>=10 alors
Résultat= [] si a ≠ 0 alors
message←''ADMIS''
2) Ecrire(''Minute: ''),lire(mm)
Ecrire(''La solution est '' , -b/a)
Sinon
3) Si mm<55 alors mm ← mm+5
sinon
Si moy>=9 alors
sinon
Si b=0 alors
message ← ''CONTROLE''
si hh<23 alors
Ecrire(''La solution est IR '')
Sinon
hh ← hh+1
Sinon
message ← ''REDOUBLE''
mm ← mm-55
Ecrire(''La
solution est vide '')
Finsi
sinon
Finsi
FinSi
hh ← 0
FinSi
moy=Donnée(''Donner une moyenne '')
mm ← mm-55
Fin Décision
a=Donnée('' Donner a : '')
FinSi
Objet
Type/nature
T.D.O
b=Donnée(''Donner b : '')
FinSi
Fin Équation
4) Ecrire(''Après 5 min : '', hh, '' :'', mm)
Moy
Réel
5) Fin Plus5min
Message
Chaîne de caractère
T.D.O
Programme pascal :
Algorithme :
program plus5min ;
Objet
Type/nature
0) Début décision
uses wincrt ;
1) Écrire(''Donner une moyenne'') , lire(Moy)
a,b
réel
var
hh,mm : integer ;
2) si moy>=10 alors message ← ''ADMIS''
Begin
Sinon
write('Heure : ') ;readln(hh) ;
Si moy>=9 alors message ← ''CONTROLE'' 3) Algorithme
Sinon message ← ''REDOUBLE''
write('minute : ') ;readln(mm) ;
0) Début Equation
Finsi
if mm<55 then mm := mm+5
FinSi
1) Ecrire('' Donner a : ''), lire(a)
else
3) Ecrire(message)
2) Ecrire(''Donner b : '') , lire(b)
if hh<>23 then
4) Fin décision
3) si a ≠ 0 alors
begin
Programme Pascal :
Ecrire(''La solution est '' , -b/a)
hh:= hh+1 ;
sinon
mm:= mm+5-60 ; program decision ;
uses wincrt ;
si b=0 alors
end
var
moy : real ; message : string ;
Ecrire(''La solution est IR '')
else
Begin
Sinon
begin
write('Donner une moyenne') ; readln(Moy) ;
Ecrire(''La solution est vide '')
hh:=0 ;
if moy>=10 then message:= 'ADMIS'
Finsi
mm := mm-55 ;
else
FinSi
end ;
if moy>=9 then message := 'CONTROLE'
4)
Fin
Equation
writeln('Après 5 min : ', hh, ' :', mm) ;
else message := 'REDOUBLE' ;
End.
Writeln(Message) ;
end.

4)Programme Pascal :
program equation ;
uses wincrt ;
var
a,b : real ;
begin
writeln('Donner a : ') ; readln(a) ;
writeln('Donner b : ') ; readln(b) ;
if (a<>0) then writeln('La solution est', -b/a)
else
begin
if (b=0) then
writeln('La solution est IR')
else
writeln('La solution est vide') ;
end ;
end.
Exercice 4 :
Saisir une chaîne de caractère et vérifier si
elle est composée de plusieurs mots.
Algorithme :
0) Début mots
1) Ecrire("Saisir une chaine :"), Lire(ch)
2) si pos(" ",ch)=0 alors écrire (''un seul mot'')
sinon écrire ('' plusieurs mots'')
Finsi
3) Fin mots
Exercice 5 :
Écrire un programme intitulé TOUCHE, qui
affiche selon le cas, la nature du
caractère( consonne, voyelle, chiffre ou
symbole) correspondant à une touche saisie.
Program touche ;
uses wincrt ;
var
nature : string ; c : char ;
begin
writeln('Taper une touche') ; readln(c) ;
case c of
'a'..'z','A'..'Z': if upcase(c) in ['A','E','I','O','U','Y']
then nature:='voyelle'
else nature:='consonne' ;
'0'..'9' : nature:= 'Chiffre' ;
else nature:='symbole' ;
end ;
writeln(nature) ;
end.


Aperçu du document fiche2-ex-if-case.pdf - page 1/1



Télécharger le fichier (PDF)

fiche2-ex-if-case.pdf (PDF, 107 Ko)

Télécharger
Formats alternatifs: ZIP



Documents similaires


fiche2 ex if case
correctionseriecoursstructuresconditionnelles
serie revisioncorrection
serie revision corrige
fiche4 ex iterative2
fiche3 ex iterative1

Sur le même sujet..