serie2 info correction .pdf


Nom original: serie2 info correction.pdfAuteur: usr

Ce document au format PDF 1.5 a été généré par Microsoft® Word 2013, et a été envoyé sur fichier-pdf.fr le 01/04/2020 à 17:32, depuis l'adresse IP 105.67.x.x. La présente page de téléchargement du fichier a été vue 39 fois.
Taille du document: 768 Ko (4 pages).
Confidentialité: fichier public

Aperçu du document


Série N° 2 : Les structure Alternatives2019
Exercice 1
Ecrire un algorithme qui demande un nombre à l’utilisateur, et l’informe ensuite si ce nombre est
strictement positif ou non.

Algorithme prod-positif
var n : réel
début
écrire (« donner un nombre : »)
lire( n)
si n > 0 alors
écrire(‘’Positif strict’’)
sinon
écrire(‘’Non positif strict’’)
finsi
fin
Exercice 2
Ecrire un algorithme qui demande l’âge d’un enfant à l’utilisateur. Ensuite, il l’informe de sa catégorie
• "Poussin" de 6 à 7 ans
• "Pupille" de 8 à 9 ans
• "Minime" de10 à 11 ans
• "Cadet" après 12 ans
Peut-on concevoir plusieurs algorithmes équivalents menant à ce résultat?

Algorithme catégorie
Variable âge :Entier
Début
écrire("Entrez l’âge de l’enfant : ")
lire( âge)
si âge ≥ 12 alors
écrire("Catégorie Cadet")
sinon
si âge ≥ 10 alors
écrire("Catégorie Minime")
sinon
si âge ≥ 8 alors
écrire("Catégorie Pupille")
sinon
si âge >= 6 alors
écrire("Catégorie Poussin")
finsi
finsi
finsi
finsi
fin
Exercice 3
Écrire un algorithme qui lit un entier et vérifie si cet entier est divisible par 3 écrire un algorithme qui lit
un entier et vérifie si cet entier est divisible par 3.

Algorithme div_3
Variable nbr :entier
Début
Écrire (« donner un entier :)
Lire(nbr)
Si (nbrMOD3=0)alors
Ecrir ( nbr, ‘est divisible par3’)
Sinon
Ecrir (nbr,’n’est pas divisible par 3)

Finsi
Fin
Exercice 4
Ecrire un algorithme qui prend deux nombres réels en entrée et qui l’informe l’utilisateur si leur
produit est négatif ou positif (on considère 0 comme positif).

Algorithme signe
variable n,m : réel
début
écrire (« donner les nombres : »)
lire( n)
lire( m)
si (n ≥ 0 et m ≥ 0) ou (n < 0 et m < 0) alors
ecrire(‘’Positif’’)
sinon
ecrire(‘’Négatif’’)
finsi
fin
Exercice 5
Ecrire un algorithme permettant de simuler une calculatrice à 4 opérations (+, -, *, et / ).

Algorithme calculatrice
Var val1,val2 : Réel
opération: caractère
Début
Ecrire("Première opérande="), Lire(val1)
Ecrire("Opération="), Lire(opération)
Ecrire("Deuxième opérande="), Lire(val2)
Suivant opération Faire
"+" : Ecrire("Résultat =", val1 + val2)
"-" : Ecrire("Résultat =", val1 - val2)
"*" : Ecrire("Résultat =", val1 * val2)
"/" : Si ( val2 # 0) Alors
Ecrire("Résultat =", val1 / val2)
Sinon
Ecrire("Division par zéro!")
FinSi
Fin

Exercice 6
Ecrire un algorithme qui teste si une note saisie au clavier est comprise entre 0 et 20.

Algorithme :

Algorithme Tester_une_note
Variables Note : réel
Message : chaîne

Début
Ecrire("Donnez une note : ")
Lire(Note)
Si Note >= 0 Et Note <= 20 Alors
Message ← "La note " , Note , " est correcte"
Sinon
Message ← "La note " ,Note , " est incorrecte"
FinSi
Ecrire(Message)
Fin

Exercice 8
Un magasin de reprographie facture 0,10dh les dix premières photocopies, 0,09dh les vingt suivantes
et 0,08dh au-delà. Ecrire un algorithme qui demande à l’utilisateur le nombre de photocopies
effectuées et qui affiche le coût total des photocopies.

Algorithme photocopies
Var n : entier
p : réel
début
ecrire("Nombre de photocopies : ")
lire(n)
si n ≤ 10 alors
p ← (n × 0.1)
sinon
si n ≤ 30 alors
p ← (10 × 0.1 + (n – 10) × 0.09 )
sinon
p ←( 10 × 0.1 + 20 × 0.09 + (n – 30) × 0.08)
finsi
finsi
ecrire("Le prix total est: ",p)
fin

Exercice 9
Ecrire un algorithme qui demande à l’utilisateur d’entrer une heure précise en demandant l’heure
puis les minutes et affiche l’heure qu’il sera une minute plus tard. Par exemple, si l'utilisateur tape 21
puis 32, l'algorithme doit répondre 21 heure(s) 33. Si l’utilisateur tape 23 puis 59, la réponse doit alors
être 0 heure 00. On considère que les valeurs entrées par l’utilisateur sont correctes.
algorithme heure
var h,m : entier
début
lire(h)
lire(m)
m←m+1
si m = 60 alors
m←0
h←h+1
si h = 24 alors
h←0
finsi
finsi
ecrire(‘’ heures ’’ ,h, ‘’min’’,m)
fin

Exercice 10

Donnez un algorithme qui lit sur l'entrée une valeur représentant une somme d'argent et qui calcule et
affiche le nombre de billets de 200 DH, 100 DH, 50 DH et 20 DH, et les pièces de 10 DH, 5 DH, 2 DH,
et 1 DH.

Le programme est :
Variables S, a : Réel
DEBUT
Ecrire « Entrez la somme d'argent : »
Lire S
Si S >= 200 Alors
a ← S \ 200
S ← S Mod 200
Ecrire « Le nombre de billets de 200 DH est : », a
FIN Si
Si S >= 100 Alors
a ← S \ 100
S ← S Mod 100
Ecrire « Le nombre de billets de 100 DH est : », a
FIN Si
Si S >= 50 Alors
a ← S \ 50
S ← S Mod 50
Ecrire « Le nombre de billets de 50 DH est : », a
FIN Si
Si S >= 20 Alors
a ← S \ 20
S ← S Mod 20
Ecrire « Le nombre de billets de 20 DH est : », a
FIN Si
Si S >= 10 Alors
a ← S \ 10
S ← S Mod 10
Ecrire « Le nombre de Piéce de 10 DH est : », a
FIN Si
Si S >= 5 Alors
a←S\5
S ← S Mod 5
Ecrire « Le nombre de Piéce de 5 DH est : », a
FIN Si
Si S >= 2 Alors
a←S\2
S ← S Mod 2
Ecrire « Le nombre de Piéce de 2 DH est : », a
FIN Si
Si S >= 1 Alors
a←S\1
S ← S Mod 1
Ecrire « Le nombre de Piéce de 1 DH est : », a
FIN Si
FIN


serie2 info correction.pdf - page 1/4


serie2 info correction.pdf - page 2/4


serie2 info correction.pdf - page 3/4

serie2 info correction.pdf - page 4/4


Télécharger le fichier (PDF)

serie2 info correction.pdf (PDF, 768 Ko)

Télécharger
Formats alternatifs: ZIP



Documents similaires


serie2 info correction
serie revisioncorrection
correctionseriecoursstructuresconditionnelles
support1
serie revision corrige
algorithme c

Sur le même sujet..